engine from hell - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 07-01-2014, 09:26 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
engine from hell

I have an 03 F-250 6.0 and have been trying to fix it for 3 weeks now.

First started off blowing black smoke,
changed all the fluids and filters, no help
took it to the shop, 4 and 8 injectors were gone,
replaced those,
still blowing smoke, but a white smoke now,
brought it back in,
said the turbo was leaking.
bought and installed brand new Garrett turbo.
blowing blue smoke now only when accelerating, and running rough at idle
had an exhaust leak so replaced the manifold gaskets
still blowing blue smoke now only when accelerating, and running rough at idle,
Took it to ford, they said it was the FICM
they replaced that and said the 1 and 8 injector had low compression, and it was something internal in the motor causing it to blow blue smoke and run rough
after spending over 4000 dollars on allllll of that i reallllly dont want to pay ford to go through it, so my boyfriends taking the motor apart and noticed the high pressure oil rail is leaking, could that cause it to run rough on idle and blow blue smoke?

or any other ideas what internally could cause this?

any advice is appreciated!!!
thank you in advance
livvgalanti is offline  
post #2 of 6 Old 07-01-2014, 09:44 AM
Member
 
Berto's Avatar
 
Join Date: Sep 2013
Location: Louisiana
Posts: 87
Thanks: 3
Thanked 5 Times in 5 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Had a buddy same truck very similar problems had it for 4 months dropped 6 Grand in it and sold it still running like complete ****. It seems like a trend with the early 6.0s
Berto is offline  
post #3 of 6 Old 07-01-2014, 09:54 AM
Super Moderator

 
Heavy_GD's Avatar
 
Join Date: Aug 2013
Location: 804Va
Posts: 12,697
Thanks: 3,567
Thanked 929 Times in 872 Posts
Mentioned: 78 Post(s)
Quoted: 1019 Post(s)
Feedback Score: 3 reviews
Do you have a monitor?

GD - 06 CCSB FX4 Lariat

https://www.gofundme.com/2464axqr

Quote:
Originally Posted by 6.0Stroker View Post
It's Toren. .. don't question it ..
Heavy_GD is offline  
post #4 of 6 Old 07-01-2014, 09:56 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Heavy_GD View Post
Do you have a monitor?
unfortunately not
livvgalanti is offline  
post #5 of 6 Old 07-01-2014, 09:59 AM
Compression Ignition Addict
 
Join Date: Jul 2013
Posts: 184
Thanks: 2
Thanked 12 Times in 11 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by livvgalanti View Post
said the turbo was leaking.
Would you be able to elaborate on this more? I'm not sure how a turbo could "leak". Unless they mean at the oil drain tube or the oil feed tube. Either of those are replacement parts or orings. An entire new turbo shouldn't be needed just to fix this I wouldn't think.

Regarding the FICM. I wouldn't have installed the stock one again. Did they give you a reason? Did they say the voltage was out of spec? The after market 58v units are the goto solution to the FICM problems.

Have you done the 'blue spring' update yet? You probably have, but if not I would get that installed.
Seattle60 is offline  
post #6 of 6 Old 07-01-2014, 10:11 AM
Super Moderator

 
Heavy_GD's Avatar
 
Join Date: Aug 2013
Location: 804Va
Posts: 12,697
Thanks: 3,567
Thanked 929 Times in 872 Posts
Mentioned: 78 Post(s)
Quoted: 1019 Post(s)
Feedback Score: 3 reviews
Quote:
Originally Posted by Heavy_GD View Post
Do you have a monitor?
Quote:
Originally Posted by livvgalanti View Post
unfortunately not

GD - 06 CCSB FX4 Lariat

https://www.gofundme.com/2464axqr

Quote:
Originally Posted by 6.0Stroker View Post
It's Toren. .. don't question it ..
Heavy_GD is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome