"Smokin' " 6.0 L - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-28-2005, 10:21 AM
Powerstroke.org Rookie
 

Join Date: Aug 2005
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question "Smokin' " 6.0 L

We purchased a new 05' Ford Excursion in July. We put a Banks exhaust system on it and noticed it smoking a little when we first start it up and when we get on it. Now we have added an AFE (Advanced Flow Engineering) air filter kit to it and now it smokes after it's been running about 2 minutes when we first start it. Now the check engine light has come on. We just did our first oil change at 3000 miles. Everything else seems fine. Anyone with any ideas on what could be makin' it smoke?

Last edited by HiTechRedneck; 08-28-2005 at 10:48 AM. Reason: spelling
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-28-2005, 01:13 PM
Compression Ignition Addict
 

Join Date: Aug 2005
Location: Greenwood, Indiana (Indianapolis)
Posts: 7,241
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Send a message via AIM to 99Smokin73Stroker Send a message via Yahoo to 99Smokin73Stroker
good smoke or bad?

What color is the smoke? Do you have only the intake and exhaust, no chip?
Reply With Quote Quick reply to this message
  #3  
Old 08-28-2005, 01:56 PM
Gun Nut




 

Join Date: Jul 2005
Location: Katy, Texas
Posts: 13,816
Thanks: 6
Thanked 31 Times in 22 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rodslinger
I'd pull that AFE and see if it fixes the problem. Since you didn't mention having a tuner I'd bet that AFE is the cause. Less air OR more fuel will cause smoking and since you didn't mention a tuner I'd check and see if it's the AFE causing less air.
Reply With Quote Quick reply to this message
  #4  
Old 08-29-2005, 06:03 AM
Powerstroke.org Rookie
 

Join Date: Aug 2005
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thanks for your help and for gettin' back to me so quick. I really appreciate it. Gonna put it on the scanner today and then work from there. Hopefully it is something as simple as the AFE.
Reply With Quote Quick reply to this message
  #5  
Old 08-29-2005, 02:11 PM
Gun Nut




 

Join Date: Jul 2005
Location: Katy, Texas
Posts: 13,816
Thanks: 6
Thanked 31 Times in 22 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rodslinger
Be sure and let us know what it was!
Reply With Quote Quick reply to this message
  #6  
Old 08-30-2005, 05:31 AM
Powerstroke.org Rookie
 

Join Date: Aug 2005
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Absolutely! Hopefully it will be something really minor and we'll be able to save someone else a big headache.
Reply With Quote Quick reply to this message
  #7  
Old 08-30-2005, 05:33 AM
Powerstroke.org Rookie
 

Join Date: Aug 2005
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
gray/white and it dissapates quickly. Heard it may be coolant. Check engine light now comes on and goes off at different times. Calling the dealership today.......
Reply With Quote Quick reply to this message
  #8  
Old 09-09-2005, 02:34 PM
Compression Ignition Addict
 

Join Date: Aug 2005
Location: Hudson, NY
Posts: 487
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
any word on the result of your problem?
Reply With Quote Quick reply to this message
  #9  
Old 09-12-2005, 05:55 AM
Powerstroke.org Rookie
 

Join Date: Aug 2005
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The Excursion is going into the shop today. The guy working on it is dialing the computer in so the check engine light will not come on for things that it doesn't need to and update the programming so it will understand that all the airflow it is getting is ok. Hopefully this should take care of the problem. He feels the EGR valve is being opened because the sensors are confused by all of the airflow and opening up the valve, resulting in the smoke coming out.

I will definitely keep everyone posted as we find out. We really appreciate all who have replied with their opinions and experience. We hope we can help the next person this happens to.

Last edited by HiTechRedneck; 09-12-2005 at 06:00 AM.
Reply With Quote Quick reply to this message
  #10  
Old 09-22-2005, 06:49 AM
Powerstroke.org Rookie
 

Join Date: Aug 2005
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Update 9/22/05

Hey guys and gals,
Here is the latest....we got the excursion back on the 13th. They told us that they upgraded and replaced what they said they would. At that time the check engine light was not on but they told us that it WOULD come back on in a day or so but to keep driving it and it will go out after a few times of having the key turned off and on. They said to drive it for awhile and if it never went out to bring it back again. The light did come on when I was on my way to work the very next morning. It has been on since.
A guy at another shop bought an 05' PSD and had the same problem, did the same upgrades as us, had the same routine done at the dealership, his light came on and went off after awhile.
We are trying to get in touch with him now to see just how long he let it go.....hopefully the light will go off SOON or we will be taking it back AGAIN!!
Just wanted to keep you guys posted. Anyone else havin' this problem yet??
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:04 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors