Front cover/engine oil pump install questions - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-24-2014, 08:21 PM
Premium Member
 

Join Date: May 2014
Posts: 241
Thanks: 2
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
Front cover/engine oil pump install questions

So installed a new 05 front cover on my 03. Everything went great up until I was looking around online and saw a thread where the oil pump was marked with dampner side on one side of both pieces.

I didnt notice it before I put mine together and to be honest didnt look for it but when I looked over the parts I think I would have noticed lettering on one side.

Anyways hoping some more knowledgable guys or ones with a manual can chime in.

Thanks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-25-2014, 02:37 AM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: port arthur texas
Posts: 3,514
Thanks: 0
Thanked 20 Times in 19 Posts
Feedback Score: 0 reviews
If you are building pressure I wouldn't worry to much. Some I have installed have been marked and others no mark at all.
I have no clue why, all were bought from Ford dealers.
Reply With Quote Quick reply to this message
  #3  
Old 06-25-2014, 06:08 AM
Premium Member
 

Join Date: May 2014
Posts: 241
Thanks: 2
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
Its still in the process of being put back together so wont know till I start it if its building pressure. Everything went to gether piece of cake but I was still a little worried.

The one I took out I measured all over and couldnt find any difference to suggest a mounting direction.

Thanks for the input.
Reply With Quote Quick reply to this message
  #4  
Old 06-25-2014, 12:21 PM
Powerstroke.org Rookie
 

Join Date: Jun 2014
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I've never seen a 6.0 oil pump marked with anything. It doesn't matter which side was installed first. On the 7.3 though, its a different story. You're good to go.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:13 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors