chugging and sputtering after egr delete and oil cooler - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-11-2014, 04:00 PM Thread Starter Fanatic
Join Date: Aug 2013
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
chugging and sputtering after egr delete and oil cooler

I was heading to the mechanic to get an egr delete and new oil cooler on my 2003 6.0, and it kinda chugged a bit. So he hooked the machine up and said it showed the egr valve jumping so he put the plate for the delete over the hole for the egr valve. And I called him to see if he was getting close to done, and he said it was chugging and sputtering some. He said he has the scanner hooked up now. Anyone else have this problem? Or no what it could be? Thanks guys.
HardcoreFx4 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome