Superchips - wastegateproblem - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-28-2006, 02:40 AM
Powerstroke.org Rookie
 

Join Date: Nov 2006
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Superchips - wastegateproblem

Hi!

I live in Norway and own a 2004 F250 with the 6-liter powerstroke. When I first used the Superchips tuning, it worked fine for a couple og weeks. Then the truck started smoking and would not work properly and after 3 months (!!!) at the Ford dealer, they found out that the wastegatevalve was broken. The truck was back on the road again a month ago and after receiveing a software upgrade from Superchips, I once again tried it. But today, after just 5 days, the wastegatevalve broke again.

Does anyone recognoze this problem? I had the impression that Superchips was a serious company as their product has worked fine for a long time on my E350 7,3, but I am starting to wonder what kind of #### this really is..

Pease, if anyone can help I would be greatful. Thank you!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-28-2006, 02:58 AM
Compression Ignition Addict
 

Join Date: Oct 2006
Location: FREEDOM, OHIO
Posts: 1,046
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well Welcome to powerstroke.org! Sorry to hear about your troubles! I own an 04 and do not know anything about the super chips but I am sure someone will be on shortly that may be able to help you out!
Reply With Quote Quick reply to this message
  #3  
Old 11-28-2006, 03:31 AM
Powerstroke.org Rookie
 

Join Date: Nov 2006
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
wastegate

ok.. someone just told me that there is no wastegate on the 6.0...

My Forddealer told me the problem was the valve that controls the turbopressure. This valve is situated on the turbo according to them. They replaced the turbo also. Bear in mind that this is a seldom truck in this country and the know-how at Forddealers is not very good..

Anyway, what happens is this: Everything i normal ubtil I hit about 3000rpm. Then i starts smoking and basically will not accelerete any more.

Sorry about my english. Does any of this make any sense??
Reply With Quote Quick reply to this message
  #4  
Old 11-28-2006, 03:45 AM
Compression Ignition Addict
 

Join Date: Oct 2006
Location: FREEDOM, OHIO
Posts: 1,046
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The person that pmed you was one of our techs and I had him take a look at your link. He is gone now but I am sure with that description it should give him a better clue as to what you are talking about. And yes the 6.0's do not have what they call a wastegate. Those were only on the 7.3's
Reply With Quote Quick reply to this message
  #5  
Old 11-28-2006, 05:13 AM
Powerstroke.org Rookie
 

Join Date: Feb 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It sounds like a possible exhaust back pressure sensor or EGR valve.
Which both are very common Ford 6.0L problems. With or withour tuning these parts are commonly failing in the states.
It doesn't have anything to do with tuning.

Maybe a couple of techs can help with a closer diagnosis with there experiance.

Ron
Reply With Quote Quick reply to this message
  #6  
Old 11-28-2006, 06:08 AM
Powerstroke.org Rookie
 

Join Date: Nov 2006
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Tuning

Thanks for that info. I do think it is connected to tuning though. I drove the truck for more than a year. Then tunes it and then this happendned just a few weeks later.

When the truck came back from Ford, i drove it for almost a month, then reconnected the Superchip tuner and now it broken again after just 4 days..
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:16 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors