U0407 code no glowplug dash light - Ford Powerstroke Diesel Forum
 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 Old 02-03-2014, 04:54 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2014
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
U0407 code no glowplug dash light

Hi everyone. New to the forum. I have a 2005 f-350 with the 6.0 diesel. I've noticed rough starts in the morning when extremely cold. No smoke just lots of shaking. Plugging into the block heater helps. I am getting a code of u0407 and the glow plug light on the dash does
Not illuminate. I can not hear the glow plugs either when turning the key forward. Suggestions for a fix?


Sent from AutoGuide.com Free App
jeff112084 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 02-03-2014, 06:00 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2014
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Bump


Sent from AutoGuide.com Free App
jeff112084 is offline  
post #3 of 13 Old 02-04-2014, 04:16 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2014
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Anybody?


Sent from AutoGuide.com Free App
jeff112084 is offline  
post #4 of 13 Old 02-04-2014, 06:45 AM
information regurgitator

 
NYC F-350's Avatar
 
Join Date: Dec 2010
Location: Epping, NH
Posts: 6,350
Thanks: 37
Thanked 270 Times in 246 Posts
Mentioned: 15 Post(s)
Quoted: 49 Post(s)
Feedback Score: 0 reviews
This is the only thing I can find about that code.

U0407 Invalid Data Received From Glow Plug Control Module


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Please
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

You could save the life of a sick child
NYC F-350 is offline  
post #5 of 13 Old 02-04-2014, 08:57 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2014
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
That is all I can find as well. I can not find a solution to the problem




Sent from AutoGuide.com Free App
jeff112084 is offline  
post #6 of 13 Old 02-05-2014, 02:58 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2014
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Anyone else have any input?


Sent from AutoGuide.com Free App
jeff112084 is offline  
post #7 of 13 Old 02-05-2014, 04:25 PM
Compression Ignition Addict
 
Join Date: Dec 2008
Location: port arthur texas
Posts: 4,222
Thanks: 1
Thanked 66 Times in 62 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Well you can have an actual error from the module or simply a blown bulb.
If it's the module it is not serviceable only replaceable.
If it is the bulb and you have an 05 or newer that will take a new cluster.

Sorry to ruin your day but it is what it is.


Lord I shall lead them to the water but I will not try to make them drink
dannyboy950 is offline  
post #8 of 13 Old 02-05-2014, 04:56 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2014
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thanks Dannyboy. The dash light will come on for a second when I first flip the key to aux with the other dash lights, however it will not stay on. I was hesitant to replace the control module due to the cost. I was afraid that would not be the issue. Do you think if I change the module it will solve the issue?


Sent from AutoGuide.com Free App
jeff112084 is offline  
post #9 of 13 Old 02-05-2014, 05:08 PM
Compression Ignition Addict
 
wvrrcarknocker's Avatar
 
Join Date: Sep 2012
Location: Louisville, KY
Posts: 422
Thanks: 13
Thanked 16 Times in 16 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 3 reviews
Send a message via Yahoo to wvrrcarknocker
I'd check the Glow Plug Module connections first. Possible they're loose, corroded or otherwise, but I doubt it. Otherwise, sounds like a dead Glow Plug Module. If you need a replacement, part number is YC3Z-12B533-AA, $132.50 delivered from Sunrise Ford Parts.

Quote:
Originally Posted by ChiefRocka View Post
Great truck, but ugly and I felt like I was driving a penis down the road .....
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wvrrcarknocker is offline  
post #10 of 13 Old 02-05-2014, 05:17 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2014
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thank you very much



Sent from AutoGuide.com Free App
jeff112084 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome