Possible Boost leak?? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-19-2014, 09:50 AM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Location: Missoula Montana
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Possible Boost leak??

Okay so i have a 04 6.0 with 5'' TB exhaust and the H&S minimax. when i get to pushing a lot of boost (like upwards of 20lbs or more) when the torque converter locks its like the truck falls on its face and has no power then just belches black smoke until i let off the throttle and step back into it, then you can hear the turbo spool back up? AHH ive been trying to figure this out for quite awhile now. i took off the intercooler boots and put them on with hairspray and and i think it may have helped a little bit but not much.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-19-2014, 01:50 PM
Powerstroke Techie

 

Join Date: Aug 2010
Location: Sassamansville, Pa
Posts: 9,594
Thanks: 80
Thanked 175 Times in 140 Posts
Feedback Score: 3 reviews
Does the truck do this when running the stock tuning?


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #3  
Old 01-22-2014, 10:29 AM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Location: Missoula Montana
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No which has me stumped, the truck doesn't do it in stock at all. i uninstalled the h&s tune and returned the truck to stock and stood on it getting onto the freeway and i pushed 24 lbs boost which seems normal? i reinstalled the tune and put it on performance (+120hp) and like always when the torque converter locked the truck fell on its face and had ZERO power until i let off then the turbo re-spooled and is fine
Reply With Quote Quick reply to this message
  #4  
Old 01-22-2014, 11:11 AM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Location: Missoula Montana
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ill also add that when i have no boost and i get into the throttle my EGT's go through the roof. Not sure if these are related, but in town my EOT and ECT are about the same (185-187) the minute i get on the highway im around 200-206 EOT and 185-190 ECT empty. with two sleds on the deck my EOT has been 220 before and my ECT around 200-208. the delta never exceeds 20*. if i pull a big hill where im pushing alot of boost on the highway once i reach the top of the hill i can feel the engine miss ONCE (all it sounds like is the turbo respools)? or all the sudden ill have no power and once i let off the throttle and get back into it the turbo respools and is fine.
Reply With Quote Quick reply to this message
  #5  
Old 01-22-2014, 08:15 PM
Powerstroke Techie

 

Join Date: Aug 2010
Location: Sassamansville, Pa
Posts: 9,594
Thanks: 80
Thanked 175 Times in 140 Posts
Feedback Score: 3 reviews
I would contact H&S to see if it's a tuning/software issue first.


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:33 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors