2003 F350 6.0 - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-14-2014, 01:06 PM Thread Starter
Powerstroke.org Rookie
Join Date: Jan 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Unhappy 2003 F350 6.0

Replaced STC Connector, FEMC replaced and Glow plug CM and fuel filter replaced. Cranks but won't start. Will start with starting fluid but won't keep running if RPM drops below 1,000. This is not my truck, it is my brothers. It is his everyday work truck and if it isn't running he isn't making money. Was told to replace High pressure fuel regulator. I would like to fix this in one last fix, so I came here. All the other stuff I've done has gotten it to at least start with the fluid, but now it wont start without using that. I also don't have the glow plug light coming on anymore. Don't know if that has anything to do with why it won't start without the starting fluid or not.
JDW588 is offline  
post #2 of 4 Old 01-14-2014, 01:15 PM
Compression Ignition Addict
kinnisoj's Avatar
Join Date: Jun 2012
Location: Trinidad Colorado ,USA
Posts: 6,085
Thanks: 136
Thanked 197 Times in 192 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
Your gonna make most guys on here scream with fear stating that you are using starting fluid. Ill be honest Im not 100% sure why its bad with the 6.0 but I know it is.
Do you have any kind of monitor on the truck or anything to check for trouble codes?

BPD OIL COOLER W/COLD WEATHER PACK & BPD oil bypass amsiol filter
,edge turbo timer
kinnisoj is offline  
post #3 of 4 Old 01-14-2014, 01:37 PM
Super Moderator

Heavy_GD's Avatar
Join Date: Aug 2013
Location: 804Va
Posts: 13,186
Thanks: 3,606
Thanked 1,009 Times in 948 Posts
Mentioned: 92 Post(s)
Quoted: 1117 Post(s)
Feedback Score: 3 reviews
The first reason is the hot glow plug being sprayed with combustible fluid, the second is the engine is already high compression and the starting fluid will only increase the combustion.

Carry on with the trouble shooting.
Heavy_GD is offline  
post #4 of 4 Old 01-14-2014, 05:16 PM Thread Starter
Powerstroke.org Rookie
Join Date: Jan 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Replaced IPR and fired right up. Started using gas and diesel mixture to start. started alot better. Now i just have to find out why the glow plug light doesn't come one.
JDW588 is offline  

6.0 , 6.0 engine help , f350 6.0 , won't start

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome