P2614 no start - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 12-29-2013, 01:35 PM Thread Starter
Member
 
Join Date: Feb 2010
Posts: 30
Thanks: 8
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
P2614 no start

Hello,

I took my truck through the car wash and it died on the way home.. Ive got P403, P405(EGR delete related) and a P2614. I have had this code 2 months ago and just cleared it.

I'm guessing my cam sensor went bad? Or is there something else I should check?

Thank you in advance.

2003 Excursion
- ARP Head Studs
- Victor Reinz Black Diamond Head Gaskets
- EGR Delete
- Innovative Cals
- XDP Coolant Filter
Synister is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 12-29-2013, 04:27 PM Thread Starter
Member
 
Join Date: Feb 2010
Posts: 30
Thanks: 8
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Well it starts now but misses and is undriveable. I guess Ill pick up a Cam Sensor tomorrow morning and see what happens.

2003 Excursion
- ARP Head Studs
- Victor Reinz Black Diamond Head Gaskets
- EGR Delete
- Innovative Cals
- XDP Coolant Filter
Synister is offline  
post #3 of 4 Old 12-30-2013, 11:41 AM Thread Starter
Member
 
Join Date: Feb 2010
Posts: 30
Thanks: 8
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Well I installed the new cam sensor starts great now, still breaking upoff idle..

I guess I'll check the harness and wires.

2003 Excursion
- ARP Head Studs
- Victor Reinz Black Diamond Head Gaskets
- EGR Delete
- Innovative Cals
- XDP Coolant Filter
Synister is offline  
post #4 of 4 Old 12-30-2013, 01:10 PM Thread Starter
Member
 
Join Date: Feb 2010
Posts: 30
Thanks: 8
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Can anyone tell me how to test the cam sensor plug with a multimeter?

Ive unwrapped the cam sensor wiring to the PCM plug and it looks like someone has been here prior. Along with the red and orange wire going into the cam sensor harnes plug there is a bare wire that runs all the way into the PCM connector and appears to tee off somewhere. I should also add it appears that someone used reynolds wrap on the wires from the PCM connector to the cam sensor plug.

I'm thinking it might be better to just buy a new harnes?

2003 Excursion
- ARP Head Studs
- Victor Reinz Black Diamond Head Gaskets
- EGR Delete
- Innovative Cals
- XDP Coolant Filter
Synister is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome