Need help please! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-20-2013, 12:56 PM
Serving Our Country!
 

Join Date: Jul 2013
Location: Columbus, Georgia
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Need help please!

I am located in Columbus, GA and I just started having some issue with my 2006 F250 6.0. I believe the problem is my injectors but I want to take it to a reputable diesel shop that I can trust to check it out, since I plan on getting some other work done while it is in the shop as well. That is what I need help with, does anyone know any shops near by that they could recommend? I have found some up around Atlanta but I really do not want to get the truck towed that far up if I don't have to. Any help from anyone would be greatly appreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-20-2013, 12:58 PM
Compression Ignition Addict
 

Join Date: Jun 2012
Location: Trinidad Colorado ,USA
Posts: 5,473
Thanks: 113
Thanked 144 Times in 142 Posts
Feedback Score: 0 reviews
What are the issue's? Do you have a monitor? Maybe we can help you fix it. The 6.0 is very DIY freindly.....
Reply With Quote Quick reply to this message
  #3  
Old 10-20-2013, 01:27 PM
Serving Our Country!
 

Join Date: Jul 2013
Location: Columbus, Georgia
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I use the dashboss as a monitoring system. All of my temps and pressures were fine at the time I started having the problem, but this is what happened, I was driving at highway speeds, around 65, I put my foot into the throttle a little harder and that's when it happened, kinda like a miss and then a sorta knocking noise, shaking and loss of power with a mix of white and black smoke coming out the back pipe. I would try to get back up to speed but when ever I put my foot in it just a little the truck starts shaking pretty bad and a lot of white smoke out of the back. I just had the egr cooler replace about 3 weeks ago and I added the ipr coolant filter to the truck along with a switch to rotella ultra elc. I haven't noticed a loss in coolant at all so I don't think it is the egr cooler. I hope this helps.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:52 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors