05 6.0 running problems - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-15-2013, 09:18 AM
Compression Ignition Addict
 

Join Date: Jun 2013
Posts: 389
Thanks: 2
Thanked 17 Times in 16 Posts
Feedback Score: 0 reviews
05 6.0 running problems

Ok my brother has an 05 6.0 with SCT tuning. When he is driving it the engine will sometimes slow itself down even though the throttle position stays the same. Some times when going to accelerate the truck won't go until after 20% throttle is applied (according to the edge insight). He is also getting a code that says the FICM is out of sync. And after driving for a while the truck will crank and crank but won't start unless is sits for a while. FICM voltage is good too. We have no clue what could be causing this and he just bought a house so he doesn't have a ton of spare cash to throw at it to change parts. Any help would be greatly appreciated.

Robert

Sent from my DROID RAZR
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-15-2013, 09:50 AM
Premium Member



 

Join Date: Dec 2011
Location: Spokane, WA
Posts: 18,143
Thanks: 74
Thanked 121 Times in 112 Posts
Feedback Score: 5 reviews
I would check the high pressure oil...
Sounds like his pumps might be failing. Mine did that when I was slowly loosing HPO. It would take more throttle to do the same amount of work.

Then it died while driving because it just lost pressure.


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #3  
Old 10-15-2013, 09:50 AM
Premium Member



 

Join Date: Dec 2011
Location: Spokane, WA
Posts: 18,143
Thanks: 74
Thanked 121 Times in 112 Posts
Feedback Score: 5 reviews
Check the ICPv on the insight


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #4  
Old 10-15-2013, 10:01 AM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: port arthur texas
Posts: 3,778
Thanks: 0
Thanked 37 Times in 36 Posts
Feedback Score: 0 reviews
As long as you have no sync the FICM will not fire the injectors.
Reply With Quote Quick reply to this message
  #5  
Old 10-15-2013, 11:03 AM
Premium Member



 

Join Date: Dec 2011
Location: Spokane, WA
Posts: 18,143
Thanks: 74
Thanked 121 Times in 112 Posts
Feedback Score: 5 reviews
Quote:
Originally Posted by I_AM_RP3 View Post
And after driving for a while the truck will crank and crank but won't start unless is sits for a while


This a a VERY common symptom for a High Pressure Oil Leak. I bet this is an issue, even if it's is not the only one.

But yes, check the FICM for issues including the connections.



Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #6  
Old 10-15-2013, 11:55 AM
Compression Ignition Addict
 

Join Date: Jun 2013
Posts: 389
Thanks: 2
Thanked 17 Times in 16 Posts
Feedback Score: 0 reviews
Thanks for the fast responses. He said his insight doesn't show ICPv but does show pressure and it always stays between 550-600 and never drops.

Sent from my DROID RAZR
Reply With Quote Quick reply to this message
  #7  
Old 10-15-2013, 11:57 AM
Premium Member



 

Join Date: Dec 2011
Location: Spokane, WA
Posts: 18,143
Thanks: 74
Thanked 121 Times in 112 Posts
Feedback Score: 5 reviews
Quote:
Originally Posted by I_AM_RP3 View Post
Thanks for the fast responses. He said his insight doesn't show ICPv but does show pressure and it always stays between 550-600 and never drops.

Sent from my DROID RAZR

At idle? What about cruising? WOT?




Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #8  
Old 10-15-2013, 12:27 PM
Compression Ignition Addict
 

Join Date: Jun 2013
Posts: 389
Thanks: 2
Thanked 17 Times in 16 Posts
Feedback Score: 0 reviews
I don't have values for those, he just said they consistently increase with the RPM's

Sent from my DROID RAZR
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:56 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors