2006 6.0L surge during cold start - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-30-2013, 04:17 PM Thread Starter
RGC
Powerstroke.org Rookie
 
Join Date: Sep 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2006 6.0L surge during cold start

I have looked and asked all over and unable to find a solution to the problem. Its a 2006 6.0L powerstroke. Truck starts fine but during initial idle the rpms surge up and down. This goes on for about 1 mile of driving and goes away and runs fine the rest of the day. Only occurs after truck has sat over night. During those first few miles sitting at a stop light the truck will lunge forward with foot on brake. Oil change up to date and filters changed and no codes found and Ford has no explanation. No smoke during surging RPM's. Any help appreciated.
RGC is offline  
post #2 of 4 Old 10-01-2013, 09:34 AM
Powerstroke.org Rookie
 
Join Date: Oct 2010
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Hi, my O6 did it too. Its been a couple years but if I remember right it was a small spring related to fuel delivery. The tech Jeremiah at Team Ford in Las Vegas found the cure in the hot sheet they use to figure out weird things. Call them and ask for Jeremiah. He will remember .. 702-395-5100

Last edited by svtme; 10-01-2013 at 09:38 AM. Reason: added info
svtme is offline  
post #3 of 4 Old 10-01-2013, 11:28 AM
Premium Member

 
twoicebergs's Avatar
 
Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 3,437
Thanks: 8
Thanked 126 Times in 118 Posts
Mentioned: 4 Post(s)
Quoted: 38 Post(s)
Feedback Score: 0 reviews
^^ What he said, but it is quite possible there is another reason such as a sticky IPR or a sensor that is not reading correctly (ICP, EBP, MAF).

Frank
2007 F-250 Lariat Crew. MBM 190/50s,
KC-68 Stage 3 Turbo,
DashBoss/F/P, and a few other goodies
Stiction Problems - Fix it yourself! - http://www.powerstroke.org/forum/gen...ml#post4509754
Want to modify your injectors DIY - http://www.powerstroke.org/forum/6-0...ger-flows.html

Working for Toys
twoicebergs is offline  
post #4 of 4 Old 10-01-2013, 05:46 PM Thread Starter
RGC
Powerstroke.org Rookie
 
Join Date: Sep 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thanks, I will follow up with the spring. Go figure today it started and ran fine.
RGC is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome