Bad fuel mileage and ICP sensor??? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-19-2013, 02:53 AM Thread Starter
Moungo's Avatar
Join Date: Sep 2013
Posts: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Bad fuel mileage and ICP sensor???

Ok ive looked on this forum and cant find anyone with the same issue as mine. If there is a thread please direct me to it.

Ok so I have an 05 excursion with 118000 on it. Recently took it to Minneapolis and the CEL came on throwing 2285 2286 and 2287, icp sensor circuit low, high, intermittent... it did this right after changing fuel filters... it had some long starts before and after changing filters 3-4 seconds but it has never not started. It also idled rough at times... I cleared the codes and they came back... parked it for two days and the codes cleared themselves... it starts and idles fine seems to run fine BUT.... my fuel mileage dropped from 18 to 14.5.... im still thinkin it could be the ICP sensor but my EOT/ECT just hit a delta of 17 when it usually sat at 7-9... I get my fuel from several places ive put additives and cant get it to come back up unless I drive 60mph... I plan on backflushing the oil cooler this wknd and changing the ICP... anyone have any other things to consider? My FICM is at 48v and I have no idea how to check for leaks around the turbo... the truck is completely stock no tunes

Sent from Free App
Moungo is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome