Turbo acting up? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-18-2013, 06:51 PM Thread Starter
Powerstroke.org Rookie
Join Date: Sep 2013
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Turbo acting up?

I have 2003 6.0 with 95k miles. Factory turbo is installed. The other day i was driving and came to a parking lot to park my truck and get out when I just happened to here the turbo wind down right before I shut the truck off. I have the truck straight piped so I can hear everything it does. It would wind down for a few seconds and then take off again. This was at idle. Shortly after I got back out on the road and noticed at one time it winded down and didnt wind back up I had no power but then all of a sudden took off and winded back up... So confused as to what is happening. Vanes sticking? Sensors? HELP! I had a P0238 code to flash at me other day. OBDII and deleted it.

2003 F-250 6.0-95k miles-Edge juicew/att-Banks ram air system-straight 4in-
dirtydiesel007 is offline  
Sponsored Links

6.0, boost, turbo

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome