VGT possible? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 08-28-2013, 05:35 PM Thread Starter Rookie
Join Date: Feb 2013
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
VGT possible?

Dealing with a problem I haven't seen before. I have an 05 6.0L that must have 2 issues. 1st I keep losing communication with the vehicle via my MODIS. Sometimes I get a signal but only with the truck off, start the truck and get a no communication error. With this being said the issue I was trying to resolve is that the turbo is very noisy and produces minimal boost till around 2300+ rpm's. I would think either the veins were gummed up or an exhaust leak. The noise will dis-appear as soon as I unplug the VGT and return when plugged in. The turbo looks to be a recent re-man and I don't see or hear any exhaust leaks. I can't scan anything with the truck running. Anything sound familiar???
rsms is offline  
Sponsored Links
post #2 of 2 Old 08-29-2013, 12:05 PM
Compression Ignition Addict
Stoker0560's Avatar
Join Date: Dec 2007
Location: Grimes, Iowa
Posts: 698
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ive had toruble scanning a few of them, it was just the connection at the OBDII port, with truck off it would read fine but the vibrations of the truck running would cause a poor connection and it wouldnt read. Usually i had to hold it just right with my foot to get it to stay connected good.

as far as the turbo issue it sounds like it could be gummed up veins or could be an exhaust leak pre turbo as well causing the poor spool. with it running and VGT plugged in have someone hold there foot over the exhaust, if theres a leak your get a nasty hiss out of it..

09 F450 CC LB lariat 6.4 black on black 23k miles, stock.. (For now)...

97 F250 SC LB 4x4 7.3 05 Superduty axels, 18" King Ranch Rims, "under the knife"

Former 6.0 Owner. (05,05,03)
Stoker0560 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome