Low Boost, Stuck VGT??? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 08-27-2013, 09:06 AM Thread Starter
Member
 
Join Date: Nov 2010
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Low Boost, Stuck VGT???

I have an '06 with 138k miles on it. I was preparing for a sled pull which is coming up this friday and I notice my water methanol was not coming on. Figured out that I was only getting 20 psi boost. I get no more boost when stock than on level 5 but there is still a substantial power increase and there is no smoke (which is normal). Normally on level 5 I can get 31-33 psi. Its not a broken gauge b/c my factory one and edge attitude display low and my meth injection is not being triggered when it should be.

I am hoping that someone has had a similar problem and can assure me that I am going down the right path.

I removed the turbo and cleaned the unison ring, vanes, and really that entire area. Everything works reall smooth; didn't seem to work too bad to begin with. I am hoping that sticking vanes is the reason my boost is low; seem right?

Truck has been been studded, egr delete, Edge Juice Platinum, and water meth injection.

'06 F250 Lariat, O-Ring'd & Studded Heads, EGR Delete, 4" Exhaust, SCT X4-ID Tunes, Water/Meth Injection, TCC Switch, F-550 Rear Spring Packs, Custom Parallel Ladder Bars, 20 inch Ultra Motorsport Wheels, Duratrac Tires

https://www.youtube.com/watch?v=0E67Iu0qbR8
https://www.youtube.com/watch?v=8d4ylLCnbnE
https://www.youtube.com/watch?v=_i6iULm1vkI
https://www.youtube.com/watch?v=aBMKsv8H_h8
c85r86 is offline  
post #2 of 2 Old 08-27-2013, 07:43 PM Thread Starter
Member
 
Join Date: Nov 2010
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No Luck. Truck is back together although absolutely no change; still maxing out at 18-20 psi. Seems like the turbo is working fine below 20 psi but then stonewalls. Doesn't make sense because the truck doesn't feel like it has lost any power; feels like the truck is running completely normal but with low boost. Next step a MAP sensor???

'06 F250 Lariat, O-Ring'd & Studded Heads, EGR Delete, 4" Exhaust, SCT X4-ID Tunes, Water/Meth Injection, TCC Switch, F-550 Rear Spring Packs, Custom Parallel Ladder Bars, 20 inch Ultra Motorsport Wheels, Duratrac Tires

https://www.youtube.com/watch?v=0E67Iu0qbR8
https://www.youtube.com/watch?v=8d4ylLCnbnE
https://www.youtube.com/watch?v=_i6iULm1vkI
https://www.youtube.com/watch?v=aBMKsv8H_h8
c85r86 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome