Too High of Fuel Pressure Issue ?? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-26-2013, 12:52 PM
Compression Ignition Addict
 

Join Date: Feb 2012
Location: FL
Posts: 470
Thanks: 6
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Too High of Fuel Pressure Issue ??

Edge CTS is reading 98psi at idle. Drops to 95 on acceleration. When I shut the truck down the CTS read 35psi. Key in on position motor not running it is at 35psi.
No issues with truck as far as running . I drove it Saturday and it was normal.. Today it was reading 100PSI

I am taking reading from the cap on the filter and it is usually 58psi.
I know I should be reading from test port but I do not have the adapter yet.

I am hoping it is just the sender.

I talked to Edge and they are sending me a replacement sender.

Any thing else I can check in the meantime? I need to use the truck daily.

Any ideas?? TIA
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-27-2013, 02:06 AM
Compression Ignition Addict
 

Join Date: Feb 2012
Location: FL
Posts: 470
Thanks: 6
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
TTT

Going to pull regulator apart tonight to see if it is is blocked possibly.

Any other suggestions?
Reply With Quote Quick reply to this message
  #3  
Old 08-27-2013, 10:43 AM
RollinEarly05...now

 

Join Date: May 2008
Location: Klamath Falls
Posts: 3,250
Thanks: 22
Thanked 20 Times in 19 Posts
Feedback Score: 8 reviews
Sounds like the sensor to me… let us know what you find out.
Reply With Quote Quick reply to this message
  #4  
Old 08-27-2013, 10:59 AM
Compression Ignition Addict
 

Join Date: Feb 2012
Location: FL
Posts: 470
Thanks: 6
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by RollinEarly99 View Post
Sounds like the sensor to me… let us know what you find out.
Thanks I will. I picked up a test kit from harbor freight and going to make a temporary gauge and get a reading out of the test port tonight to see where I am at. Then from there I might have to go into it further.
Reply With Quote Quick reply to this message
  #5  
Old 08-27-2013, 11:09 AM
RollinEarly05...now

 

Join Date: May 2008
Location: Klamath Falls
Posts: 3,250
Thanks: 22
Thanked 20 Times in 19 Posts
Feedback Score: 8 reviews
I know that at 100 psi o rings and seals start becoming a serious problem.
Reply With Quote Quick reply to this message
  #6  
Old 08-27-2013, 04:00 PM
Compression Ignition Addict
 

Join Date: Feb 2012
Location: FL
Posts: 470
Thanks: 6
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by RollinEarly99 View Post
I know that at 100 psi o rings and seals start becoming a serious problem.
Yeah I have read that. When I noticed I was at 100 I turned around and went home. I had to drive about 15 miles cause I couldn't leave my excavator on the side of the road if I had to get towed.
Reply With Quote Quick reply to this message
  #7  
Old 08-28-2013, 05:40 PM
Compression Ignition Addict
 

Join Date: Feb 2012
Location: FL
Posts: 470
Thanks: 6
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Update. ..
Confirmed that it was the sender that was bad. Got a oil test gauge from Harbor Freight and plumbed into the test port. Getting 60 psi at idle which is what I was normally getting.
Edge sent me a replacement and should be in tomorrow.
Reply With Quote Quick reply to this message
  #8  
Old 08-29-2013, 10:28 AM
RollinEarly05...now

 

Join Date: May 2008
Location: Klamath Falls
Posts: 3,250
Thanks: 22
Thanked 20 Times in 19 Posts
Feedback Score: 8 reviews
Nice! Glad you found the problem.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:40 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors