need help!!!!! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-20-2013, 07:42 PM
Powerstroke.org Rookie
 

Join Date: Aug 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
need help!!!!!

hey guys iv done a few google searches and came up with nothing and i am totally lost. i dont believe in paying high prices to pay at the mechanic because i just dont have the funds and i can do the work myself just having troubles with this one. first let me start off with saying websites like these are a godsend to DIYers so thanks in advance!

I have a 2004 f250 6.0 built 05/04
it has a brand new turbo
4" catback exhaust
sct extreme street tune
4" lift
17" rockstar 2's on 35's
2" wheel spacers...

well my truck was idling a little ruff and i checked the DTC and it came up with 3 open glow plug circuits and a contribution balance code.

i replaced all the glow plugs and the wire harness but am still getting an open glow plug circuit in cyl 8

im also getting the contribution balance code on cyl 7 but im almost sure its a bad injector as it idles rough at stop lights and such.

well my new problem is this... ever since i replaced the glow plugs, my ABS light is on.. my speedo works fine so im pretty sure its not the rear speed sensor based on my speedo still working...iv also checked my dtc codes and nothing comes up regarding ABS.

What could be my problem? i checked the pigtails for the front wheels behind the inner wheel well and they seem fine... everything was fine regarding ABS prior to the glow plug fix so maybe i unplugged something somewhere else.

just a side note.. i installed the wheelspacers a few weeks ago but lifted the truck and put red threadlock on them the same day i changed the passanger side glow plugs.

can any ABS plug besides the pigtails have been disconnected somewhere when replacing the glow plugs or lifting the vehicle?

Please help!?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-09-2013, 06:55 PM
Dr. of Linemantology
 

Join Date: Mar 2009
Location: escondido, ca
Posts: 93
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check ur air lines going to each wheel for the abs system. the open circuit on injector 7- check the plug where it goes to #7 at the rocker box. it should have a metal retaining clip to hold the connection together. if u pull the plug out make sure the plug has 4 pins in it. they sometimes can recess back into the plug failing to make a connection. when putting plug back together it only goes one way so dont force it and risk bending or breaking the pins. if u dont know #7 cylinder ison passenger side closest one to fire wall and hardest one to get to. im not a tech just 9 years of learning and repairing my early 04 6.0 which u have the same motor. 5/04 6.0 were considered early 04 or 03 motors. maybe a tech will help u out. seems like u have 3 seperate issues. glow plug, abs and injector wiring. good chance that injector is not bad. have the injectors ever been changed. hope u studded that motor before u started running that tuner. there r a lot of good people and good info on how to maintain and repair this motor just got to dig around. what part of cali?
Reply With Quote Quick reply to this message
  #3  
Old 09-10-2013, 09:04 AM
Powerstroke.org Rookie
 

Join Date: Aug 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
so i just ended up taking her in when i couldnt get a hold down bolt for cylander 7 injector off... turns out i had 2 dead injectors, my glow plug module was out, and the abs harness pigtail on the dirver side pushed the pins in instead of completing the circuit..
Reply With Quote Quick reply to this message
  #4  
Old 09-10-2013, 10:44 AM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: port arthur texas
Posts: 3,726
Thanks: 0
Thanked 31 Times in 30 Posts
Feedback Score: 0 reviews
Thanks for the update
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:30 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors