6.0 has to go! - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 08-15-2013, 04:04 PM Thread Starter
Member
 
fordhorseplay's Avatar
 
Join Date: Apr 2012
Location: Mooresville, Indiana
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 has to go!

hey guys, alright after having a high pressure oil leak, fixing that and then losing all oil pressure and finding needle bearings in my LPOP, I have just about had it with the 6.0. anyone know how well a different ford diesel will fit in my 06? if I find a donor truck with a different drivetrain in it will my cab and bed fit on a newer frame and drivetrain?
I'm trying to look at all the options because I don't really want to go back to the 6.0L. if I have to go back to the 6.0L I will, but tired of the problems.
any suggestions would be greatly appreciated


Rob
06 F350 Harley Edition, CC, SB, 6"lift, 37"s, New Dynamic Diesel .030"6.0l,stage 1 colt cam,thicker revised heads,studs,Billet push rods,BPD oil cooler and water pump,AL radiator,mishimoto blue hoses,fluidamper,ATS Billet flex plate,Zoodad,AFE 5R stage 2,Blue spring, Sinister: intake,CAC tubes/boots,oil & coolant filter, 4" TB straight pipe duals 6" tips,edge insight cts, SCT(IDP, GEARHEAD), built Suncoast trans
fordhorseplay is offline  
post #2 of 9 Old 08-15-2013, 04:16 PM
Powerstroke.org Rookie
 
Join Date: Aug 2013
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just changed hpop and all injectors. Truck ran great for 2 weeks then it shut off in my yard. No oil pressure opened oil filter and it was under vacume and no oil. Decompressed plunger at bottum of filter body and got oil wile cranking. Replaced cap With motorcraft part and have motorcraft oil filter removed lpo regulator and inspected looks fine. My icp is only at 275. Any ideas.

Sent from AutoGuide.com Free App
dguad is offline  
post #3 of 9 Old 08-15-2013, 04:25 PM Thread Starter
Member
 
fordhorseplay's Avatar
 
Join Date: Apr 2012
Location: Mooresville, Indiana
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by dguad View Post
Just changed hpop and all injectors. Truck ran great for 2 weeks then it shut off in my yard. No oil pressure opened oil filter and it was under vacume and no oil. Decompressed plunger at bottum of filter body and got oil wile cranking. Replaced cap With motorcraft part and have motorcraft oil filter removed lpo regulator and inspected looks fine. My icp is only at 275. Any ideas.

Sent from AutoGuide.com Free App
you check the standpipes and dummy plugs? dummy plug on passenger side is the most common one to fail, apparently it is the last to get any oil.


Rob
06 F350 Harley Edition, CC, SB, 6"lift, 37"s, New Dynamic Diesel .030"6.0l,stage 1 colt cam,thicker revised heads,studs,Billet push rods,BPD oil cooler and water pump,AL radiator,mishimoto blue hoses,fluidamper,ATS Billet flex plate,Zoodad,AFE 5R stage 2,Blue spring, Sinister: intake,CAC tubes/boots,oil & coolant filter, 4" TB straight pipe duals 6" tips,edge insight cts, SCT(IDP, GEARHEAD), built Suncoast trans
fordhorseplay is offline  
post #4 of 9 Old 08-15-2013, 04:26 PM
Compression Ignition Addict
 
MrOneEyedBoh's Avatar
 
Join Date: Sep 2012
Posts: 2,690
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 45
Thanked 142 Times in 76 Posts
Feedback Score: 11 reviews
If you are tuned, you will get lower ICP, but I doubt THAT low. Its just something to keep in mind. Mine is tuned and I have about 500ish idle. Technically the truck shouldnt really run on that low at idle
MrOneEyedBoh is offline  
post #5 of 9 Old 08-15-2013, 04:27 PM Thread Starter
Member
 
fordhorseplay's Avatar
 
Join Date: Apr 2012
Location: Mooresville, Indiana
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
also what is the ipr duty cycle, and FICM voltage while cranking?


Rob
06 F350 Harley Edition, CC, SB, 6"lift, 37"s, New Dynamic Diesel .030"6.0l,stage 1 colt cam,thicker revised heads,studs,Billet push rods,BPD oil cooler and water pump,AL radiator,mishimoto blue hoses,fluidamper,ATS Billet flex plate,Zoodad,AFE 5R stage 2,Blue spring, Sinister: intake,CAC tubes/boots,oil & coolant filter, 4" TB straight pipe duals 6" tips,edge insight cts, SCT(IDP, GEARHEAD), built Suncoast trans
fordhorseplay is offline  
post #6 of 9 Old 08-15-2013, 04:55 PM
Powerstroke.org Rookie
 
Join Date: Aug 2013
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ipr 84% and I have 48 volts on the ficm . Do you think a leak on the high pressire oil would evacuate oil from filter faster than the lp oil could supply it?

Sent from AutoGuide.com Free App
dguad is offline  
post #7 of 9 Old 08-15-2013, 08:11 PM Thread Starter
Member
 
fordhorseplay's Avatar
 
Join Date: Apr 2012
Location: Mooresville, Indiana
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
not really sure if it leaks off faster than the LPOP can supply it but rather the pressure isn't building to get it there, I believe. but with the numbers you're getting, you have a leak. probably passenger side dummy plug.


Rob
06 F350 Harley Edition, CC, SB, 6"lift, 37"s, New Dynamic Diesel .030"6.0l,stage 1 colt cam,thicker revised heads,studs,Billet push rods,BPD oil cooler and water pump,AL radiator,mishimoto blue hoses,fluidamper,ATS Billet flex plate,Zoodad,AFE 5R stage 2,Blue spring, Sinister: intake,CAC tubes/boots,oil & coolant filter, 4" TB straight pipe duals 6" tips,edge insight cts, SCT(IDP, GEARHEAD), built Suncoast trans
fordhorseplay is offline  
post #8 of 9 Old 08-16-2013, 05:11 AM
Powerstroke.org Rookie
 
Join Date: Aug 2013
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no leaks out of dummy plug or oil rails. Maybe i got a bum hpop. Going for that next what do you think?
dguad is offline  
post #9 of 9 Old 08-16-2013, 07:50 AM
Powerstroke.org Rookie
 
Join Date: Aug 2013
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
fixed the problem clogged ipr screen. Metal shavings . Any ideas of what it is from my guess old high pressure pump or possibly lo pressure oil pump.
dguad is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome