truck runs horribly - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-13-2013, 04:13 AM
Powerstroke.org Rookie
 

Join Date: Oct 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
truck runs horribly

so while idiling last week it started loping out of no where when i hooked my ae scanner up it came back with injector 1 circuit code so yesterday i replaced injector 1 truck ran great for the most part then this morning while driving to work it started falling on its face and would idle up to around 1000 without touching the acc and truck surges at around 1200 to 2000 all the time. I hooked it back up to the ae and found p2285 but then truck started running fine and this has not occured again truck is a 03 250 i monitered icp and icp desired and pids were within range no more than 10 apart anyone have any ideas also truck has 152000 and i replaced hpop, ipr and icp along with pigtail at around 120000 also replaced ficm around 146000 any input would be aprecitated
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-13-2013, 05:32 PM
Compression Ignition Addict
 

Join Date: Jul 2013
Posts: 324
Thanks: 0
Thanked 15 Times in 15 Posts
Feedback Score: 0 reviews
Check the voltage for the FICM
Reply With Quote Quick reply to this message
  #3  
Old 09-12-2013, 05:15 AM
Serving Our Country!
 

Join Date: Sep 2012
Location: St. Marys, Ohio
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I am having the same trouble. I have the same code. I have an 03 excursion stock as far as I can tell. Bought it used through a dealer and was owned by the government before that. What have you been able to find.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #4  
Old 09-12-2013, 08:36 PM
Vintage Nakamichi Powered
 

Join Date: Sep 2012
Location: Elk Grove, California
Posts: 1,286
Thanks: 9
Thanked 34 Times in 31 Posts
Feedback Score: 0 reviews
Have you tried unplugging that icp to see if default idles smooth?
Reply With Quote Quick reply to this message
  #5  
Old 09-13-2013, 05:00 AM
Premium Member

 

Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 2,921
Thanks: 6
Thanked 78 Times in 72 Posts
Feedback Score: 0 reviews
Since it is running well now it will be tough to diagnose. It is quite possible you were still dealing with air in the system and that was causing the problem. However, if there was no air in the system, with the idle increasing all on its own, that sounds like the ICP must have also be rising. The question is whether it was a cause or a symptom. If the ICP or wiring was giving false readings, the PCM would have the IPR opening and closing incorrectly. Conversely, the IPR could have been the culprit. Just a few things to consider if the problem resurfaces.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
6.0 advice, 6.0 diesel, 6.0 injector, runs rough, surging

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:14 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors