Glow plug pin-out - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-03-2013, 06:44 AM
Powerstroke.org Rookie
 

Join Date: Aug 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Glow plug pin-out

Does anyone have a glow plug pin-out?

Here is my issue. When you first start the truck and the engine is cool it buck's and kicks like you wouldn't believe. Once the engine warms, it is fine. No codes, I've done and injector cut out and no issue found (when warm). I'm at my wits end. Could it possibly be loosing prime over night or after it sits awhile as well? I am going to test my FICM and glow plug harness but I am wondering if anyone has a pin-out of the harness so I don't go poking injector solenoids.

Truck has 90k ARPS, and had a new EGR cooler and Oil Cooler done at 50K. Filters all changed 2k ago.

Thanks for the help.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-03-2013, 11:55 AM
Premium Member
 

Join Date: May 2013
Posts: 845
Thanks: 6
Thanked 28 Times in 26 Posts
Feedback Score: 1 reviews
what is a glow plug pin-out?
Reply With Quote Quick reply to this message
  #3  
Old 08-03-2013, 03:32 PM
Serving Our Country!
 

Join Date: May 2008
Location: Le Roy, NY
Posts: 533
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
FICM by itself could cause this problem. If the FICM tests good, when is the last time you had the truck reflashed? Ford has some enhancements to cold start issues. Also maybe try an oil additive like RevX, might have some stiction issues. But when my FICM was going bad, cold starts were a beast, then it had to be plugged in for like 4 hours. Readings were good, ended up having a bad logic side. Had to put a known good one to pinpoint the problem
Reply With Quote Quick reply to this message
  #4  
Old 08-04-2013, 06:56 AM
Powerstroke.org Rookie
 

Join Date: Aug 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How did yours run warm? Did it happen to kick every once in awhile at low rpm cruise speed under load? Mine doesn't have a hard time starting, at least yet!
Reply With Quote Quick reply to this message
  #5  
Old 08-04-2013, 07:21 AM
Serving Our Country!
 

Join Date: May 2008
Location: Le Roy, NY
Posts: 533
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
when it was warm, at like highway speeds it would feel like I lost an injector or 2 without the smoke..loss of power, bucking. If I got on the skinny pedal again it would smooth out. Basically in OD it was gutless, thats when I started to realize I had a serious issue going on. At first I thought the hard starts just might be glow plug related
Reply With Quote Quick reply to this message
  #6  
Old 08-04-2013, 09:13 AM
Compression Ignition Addict
 

Join Date: Sep 2012
Posts: 156
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had same exact symptoms, needed new ficm ( make sure you test it cold), and T6 5w-40 with archoil, now just T6 in the oil and its fine.
Reply With Quote Quick reply to this message
  #7  
Old 08-04-2013, 02:36 PM
Powerstroke.org Rookie
 

Join Date: Aug 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm going to test it Saturday morning. I'll let y'all know my findings.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:26 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors