'07 6.0 rough idle - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 08-01-2013, 10:07 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
'07 6.0 rough idle

Having a problem with the truck shuddering while idling. It'll idle for about a minute then start shuddering really bad then the pedal just goes dead. No response from it. Then the truck just dies. No warning light, not throwing any codes, nothing. Replaced both fuel filters and did and oil change. Still learning my way around diesels, and not sure what this could be. Thanks for any help guys.
kneedragger627 is offline  
post #2 of 5 Old 08-01-2013, 10:22 AM
Compression Ignition Addict
 
Join Date: Jul 2013
Posts: 357
Thanks: 0
Thanked 19 Times in 19 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Try changing the ebp, you could have a electrical issue, can you drive the truck in that minute? Do you get the wrench light?
JorgeCanek is offline  
post #3 of 5 Old 08-01-2013, 10:34 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Put it in drive, and it dies quicker. No wrench light or engine light at all while its running.
kneedragger627 is offline  
post #4 of 5 Old 08-02-2013, 03:09 PM
Powerstroke.org Rookie
 
Join Date: Feb 2013
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Do you have an EGR valve? If so, get a gasket kit from Ford ($10) and clean the valve.

'06 F250 FX4 6.0
SCJScott is offline  
post #5 of 5 Old 08-02-2013, 07:10 PM
Premium Member
 
Ford_Fan1's Avatar
 
Join Date: May 2013
Posts: 1,416
Thanks: 11
Thanked 53 Times in 49 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 3 reviews
Is it a rough idle when the engine is up to operating temp or only when cold? If it is only when cold I would check your FICM volts.


"Pickle Monster"
2004 F-350 King Ranch built 3/24/04
4" lift, 5" MBRP TB back exhaust
EGR MIA ,ported intake, 05-07 intake horn
CCSB
FX4
Firestone airbag suspension in the rear with on-board compressor
Monitored with Edge Insight CS, tuned by Gearhead
high idle mod, Atlas 40 FICM tune, Cat ELC,
2008 taillights, 08 mirrors, smoked marker lights, harpooned fuel tank, DIY headache rack, Bushwacker fender flares
Ford_Fan1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome