turbo has little psi at full throttle - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 07-25-2013, 05:44 PM Thread Starter
Powerstroke.org Rookie
 
Smokinandstrokin250's Avatar
 
Join Date: Jul 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
turbo has little psi at full throttle

when im driving my 6.0 you hear the turbo whistle like its leaking and but only happens between like 2,500 rpms and 3,200 rpms but the truck has no power the turbo is putting at most 16 psi when it used to put out 25 -30 at full throttle
do i need a new turbo or what could it might be please help truck is stock except chip,intake,exhaust if i put my chip in stock it takes a long time to get up to 70 mph need help please thank you.
Smokinandstrokin250 is offline  
post #2 of 8 Old 07-26-2013, 07:39 AM
Powerstroke.org Fanatic
 
Wildcat98's Avatar
 
Join Date: May 2013
Posts: 120
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
How many miles on the truck? I would check all your turbo connections. Make sure no boots have slipped off or are
Worn/cracked, check the band clamps too! Then check the MAP sensor on the passenger side of engine compartment, there will be a hose that runs to the pass. side of the intake, same drill make sure hose is pliable, no cracks, remove fitting on intake make sure it not plugged! Last is pull the turbo and clean it up, pretty simple and there are YouTube videos out there on how.

Mine was doing what yours is doing, one silicon hose was not all the way on. Plus I had to replace the hose to the MAP sensor, and I cleaned up the turbo... I've seen 24psi since on my CTS boost gauge.

Let me know what you find!



Sent from AutoGuide.com App

2005 F250 XLT CCSB FX4
Wildcat98 is offline  
post #3 of 8 Old 07-26-2013, 07:15 PM Thread Starter
Powerstroke.org Rookie
 
Smokinandstrokin250's Avatar
 
Join Date: Jul 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have a 178,kkk miles and I'm gonna look at it Sunday thanks for your help ill let you know what I find
Smokinandstrokin250 is offline  
post #4 of 8 Old 07-30-2013, 09:21 AM
Powerstroke.org Fanatic
 
Wildcat98's Avatar
 
Join Date: May 2013
Posts: 120
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Any luck?


Sent from AutoGuide.com App

2005 F250 XLT CCSB FX4
Wildcat98 is offline  
post #5 of 8 Old 07-30-2013, 07:32 PM Thread Starter
Powerstroke.org Rookie
 
Smokinandstrokin250's Avatar
 
Join Date: Jul 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
No checked all connections on turbo all inter cooler hoses and map sensor hose is fine the up and down pipes are good there was oil in the turbo is that normal ? On the charge side to the inter cooler
Smokinandstrokin250 is offline  
post #6 of 8 Old 07-30-2013, 07:49 PM
Premium Member

 
twoicebergs's Avatar
 
Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 3,428
Thanks: 8
Thanked 125 Times in 117 Posts
Mentioned: 4 Post(s)
Quoted: 36 Post(s)
Feedback Score: 0 reviews
Quote:
there was oil in the turbo is that normal ? On the charge side to the inter cooler
It is absolutely normal.

Frank
2007 F-250 Lariat Crew. MBM 190/50s,
KC-68 Stage 3 Turbo,
DashBoss/F/P, and a few other goodies
Stiction Problems - Fix it yourself! - http://www.powerstroke.org/forum/gen...ml#post4509754
Want to modify your injectors DIY - http://www.powerstroke.org/forum/6-0...ger-flows.html

Working for Toys
twoicebergs is offline  
post #7 of 8 Old 08-01-2013, 09:30 PM Thread Starter
Powerstroke.org Rookie
 
Smokinandstrokin250's Avatar
 
Join Date: Jul 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thanks twoicebergs. I found the leak and it is the plastic pipe off the intercooler it cracked on the bottom guess I didn't see it imma buy the afe steel pipe so it won't happen again I duct taped the hose for now got all my boost back thanks for the help.
Smokinandstrokin250 is offline  
post #8 of 8 Old 08-02-2013, 11:50 AM
Powerstroke.org Fanatic
 
Wildcat98's Avatar
 
Join Date: May 2013
Posts: 120
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Smokinandstrokin250 View Post
Thanks twoicebergs. I found the leak and it is the plastic pipe off the intercooler it cracked on the bottom guess I didn't see it imma buy the afe steel pipe so it won't happen again I duct taped the hose for now got all my boost back thanks for the help.
Glad you found the leak and got it pack up to par!


Sent from AutoGuide.com App

2005 F250 XLT CCSB FX4
Wildcat98 is offline  
Reply

Tags
no power , no throttle response , turbo 6.0

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome