2003 6.0 stalls,no power, won't start..help! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-20-2013, 06:06 PM
Powerstroke.org Rookie
 

Join Date: Jul 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2003 6.0 stalls,no power, won't start..help!

New to me 03 f350 with 6.0 ran fine.... Then started bogging down .. Could not get above 1500 rpm.within 1 mile it stalled and would not restart. I pulled it back to the garage and changed the fuel filters. Motorcraft used. ..started...but only idled for 3 min then stalled. Will crank over but not start. Several times it started to chug but never really took off. If I let it set for 3-4 hours it will start only to not rev above 1500 rpm and stall in 3-5 min. Ficm voltage is 46 volts. No engine codes. Battery voltage is good. Fuel pump pumps fine to the upper fuel filter, no bubbles. Any ideas what else I should check? New to diesels but learning fast.....help!thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-20-2013, 07:02 PM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,242
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Get codes out of it. First. May help pinpointing issue. Sounds like an oil pressure issue
Reply With Quote Quick reply to this message
  #3  
Old 07-20-2013, 07:04 PM
Powerstroke.org Rookie
 

Join Date: Jul 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No codes.... Also dealer just replaced faulty water pump(was dripping) belt and did oil change.
Reply With Quote Quick reply to this message
  #4  
Old 08-05-2013, 09:26 AM
Powerstroke.org Rookie
 

Join Date: Aug 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Snowman610 View Post
New to me 03 f350 with 6.0 ran fine.... Then started bogging down .. Could not get above 1500 rpm.within 1 mile it stalled and would not restart. I pulled it back to the garage and changed the fuel filters. Motorcraft used. ..started...but only idled for 3 min then stalled. Will crank over but not start. Several times it started to chug but never really took off. If I let it set for 3-4 hours it will start only to not rev above 1500 rpm and stall in 3-5 min. Ficm voltage is 46 volts. No engine codes. Battery voltage is good. Fuel pump pumps fine to the upper fuel filter, no bubbles. Any ideas what else I should check? New to diesels but learning fast.....help!thanks!
My 2003 7.3L F350 is having the same issue. I just got an ICP sensor today and I am going to try replacing that. Also read that it might be the TPS. Let me know if you get yours fixed and I will do the same.
Reply With Quote Quick reply to this message
  #5  
Old 08-05-2013, 02:25 PM
Powerstroke.org Rookie
 

Join Date: Aug 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Replaced the ICP and did not fix. On to the next sensor.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:12 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors