Problem after ICP change - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-26-2013, 06:44 AM Thread Starter
Join Date: Sep 2009
Posts: 65
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Problem after ICP change

I finally got the ICP changed on another thread but the truck would not start. I looked at the ICP on the scan-gauge and saw 4000. Turned the key off and back on and 4000 for about 10 seconds then dropped to zero. After dropping to zero the truck starts right up. If I shut it down after idling for a few minutes with the ICP showing 875 it won't restart. As soon as I turn the key back on it goes to 4000 and won't start. If I wait it drops to zero and starts.

When it is idling normally the gauge show a solid 825. Never saw it fluctuate idling.

Any suggestions?
purplewg is offline  
Sponsored Links
post #2 of 2 Old 06-26-2013, 08:04 AM
Compression Ignition Addict
Join Date: Dec 2008
Location: port arthur texas
Posts: 4,217
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 62 Times in 58 Posts
Feedback Score: 0 reviews
Did you change the pigtail as well.

Lord I shall lead them to the water but I will not try to make them drink
dannyboy950 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome