More truck problems - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-14-2013, 09:27 AM
Compression Ignition Addict
 

Join Date: Jun 2011
Posts: 630
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
More truck problems

Well I finally figured out what was going on with my no start issue and then I was about 2 hours away from home it died going down the highway.

Truck will crank and fire but thats it. I get P0231 p2614 p2617 codes and from what I read they would be secondary fuel pump circuit is low, cam sensor, and crankshaft position sensor.

I'm lost at this point and in need of urgent help. I seen some guys say FICM but my FICM has always shown strong voltage and I've also seen some say its a wiring issue from those sensors into the computer, some sort of chaffing.

Please help! I need my truck on the road!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-14-2013, 09:52 AM
information regurgitator
 

Join Date: Dec 2010
Location: Epping, NH
Posts: 5,922
Thanks: 18
Thanked 180 Times in 167 Posts
Feedback Score: 0 reviews
Forget about the crank/cam sensors for now. Those two codes pop up after continual long cranks all the time. Also, most of the wire chafe issues were earlier models than the '06 year. Not saying it isn't possible..
Try swapping the fuel pump relay with a known good one for starters.
Reply With Quote Quick reply to this message
  #3  
Old 06-14-2013, 09:54 AM
7.3 4 Ever! Nothing else!
 

Join Date: Aug 2012
Posts: 4,169
Thanks: 1
Thanked 16 Times in 16 Posts
Feedback Score: 10 reviews
Ok i couldnt resist!!! LOL jk
More truck problems-imageuploadedbyautoguide1371232475.193177.jpg


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #4  
Old 06-14-2013, 10:27 AM
Compression Ignition Addict
 

Join Date: Jun 2011
Posts: 630
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Well I've got an airdog2 on it, should I try putting it back to stock? Seems like I've had problems ever since I put it on.
Reply With Quote Quick reply to this message
  #5  
Old 06-14-2013, 10:41 AM
information regurgitator
 

Join Date: Dec 2010
Location: Epping, NH
Posts: 5,922
Thanks: 18
Thanked 180 Times in 167 Posts
Feedback Score: 0 reviews
Check your wiring. That code points to an electrical issue somewhere. No idea how your airdog2 would cause that code other than electrical connection/bad relay.
Reply With Quote Quick reply to this message
  #6  
Old 06-14-2013, 11:55 AM
Compression Ignition Addict
 

Join Date: Jun 2011
Posts: 630
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
I'pl check all of my wiring for the airdog.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:47 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors