Funky idle - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-28-2006, 06:05 AM
Member
 

Join Date: Sep 2006
Location: Corpus Christi Area
Posts: 44
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Funky idle

The other day while the truck was idling, there was a flutter in the engine, my water light came on, it happened a few minutes later and this time it died. It restarted okay and runs great. Yesterday while sitting at a stop light, it did it again and it died and restarted. It runs great, not missing a beat, it only happens when it is at an idle. Any ideas? It is an '04 with 28k miles, no mods.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-28-2006, 06:41 AM
Powerstroke.org Sponsor
 

Join Date: Jun 2006
Location: Kelowna,B.C. Canada
Posts: 168
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Could be injecter,or EGR valve sticking,Take it to dealer and get it scanned.
Reply With Quote Quick reply to this message
  #3  
Old 10-12-2006, 07:54 PM
Compression Ignition Addict
 

Join Date: Oct 2006
Location: Texas
Posts: 174
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If its not an injector or EGR valve, you might mention to the dealer its possible its in the wiring harness. had an 04 that did the very same thing and they replaced a wiring harness(not sure which one)and the truck was flawless after that. Too bad it only took them a year and a half to figure it out.
Reply With Quote Quick reply to this message
  #4  
Old 10-12-2006, 08:07 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i cold be wrong, but i think there was a TSB for a loose or corroded ground for a similar concern.........have the dealer look into it...
Reply With Quote Quick reply to this message
  #5  
Old 11-07-2006, 10:45 AM
Powerstroke.org Rookie
 

Join Date: Jul 2006
Location: Lanett, AL
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mines rough at idle sometimes as well. A couple of months ago it was doing it so bad that it wouldn't idle. Dealer replaced ERG valve and it helped it alot but it still sputters at idle sometimes.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:04 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors