Warren diesel injector issue? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-23-2013, 12:14 PM
Compression Ignition Addict
 

Join Date: Jan 2010
Location: nj
Posts: 454
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Warren diesel injector issue?

Hey guys so last august i got 190/100's from jesse, around december the truck started to miss bad and lope. I found 5 out of the 8 were sticking. I called jesse and he warrantied them. Well its now may the truck sat for 1 week i get in today and yet again she's missing and studdering until up to operated temp. Ficms great. Oils full synthetic. No issues. Has anyone else had problems with warrens injectors? Also does anyone have his direct email? Everytime ive delt with him
I must say hes a stand up guy for sure. Any advice would help. Thanks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-23-2013, 12:39 PM
Compression Ignition Addict
 

Join Date: Jan 2010
Location: nj
Posts: 454
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Also for got to mention once up to full operating temp its smooth running. Acts exactly like it did the first time when sticking. An it's 80 degrees here in jersey so i know something not right.
Reply With Quote Quick reply to this message
  #3  
Old 05-23-2013, 01:23 PM
Compression Ignition Addict
 

Join Date: Jun 2010
Location: Douglassville, PA
Posts: 1,030
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What was the original reason for replacement (when you first put the warrens in)? What does your delta look like? Have you ever replaced the oil cooler and updated the HPOP screen?
Reply With Quote Quick reply to this message
  #4  
Old 05-23-2013, 01:26 PM
Compression Ignition Addict
 

Join Date: Jan 2010
Location: nj
Posts: 454
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Original reason was fir 190's. no issues with stock. Deltas are fine about 6-8 degree difference. Fuel pressure from my a dog is cositant at 60-65
Reply With Quote Quick reply to this message
  #5  
Old 05-23-2013, 02:09 PM
Compression Ignition Addict
 

Join Date: Jan 2010
Location: nj
Posts: 454
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Oil coolers been replaced and screen has been updated. Its doing the same thing when the spool valves were sticking. I tried contact jesse to get the warrantied.
Reply With Quote Quick reply to this message
  #6  
Old 05-25-2013, 08:06 PM
Compression Ignition Addict
 

Join Date: Nov 2011
Location: LaGrangeville,NY
Posts: 318
Thanks: 0
Thanked 7 Times in 5 Posts
Feedback Score: 0 reviews
Keep us posted, my stock injectors had some slight stiction. I just sent them to Warren for a rebuild and 155/30's, They assured me I'd have no stiction problems. Does Rev X clear your issue up?... My old stockers would clear up with rev x at every oil change on synthetic... stiction would reappear at about 4000-5000 miles like clockwork, just in time for fresh oil change.
Thanks,
Deo
Reply With Quote Quick reply to this message
  #7  
Old 05-25-2013, 08:17 PM
Banned
 

Join Date: Oct 2011
Location: Carrollton Ohio
Posts: 8,839
Thanks: 65
Thanked 55 Times in 37 Posts
Feedback Score: 10 reviews
You can try to remove them and disassemble the spool valves and polish them up with some fine grit sand paper and try that. Usually works pretty well.
Reply With Quote Quick reply to this message
  #8  
Old 05-26-2013, 04:56 AM
Compression Ignition Addict
 

Join Date: Jan 2010
Location: nj
Posts: 454
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yeah. Not really sure why these injectors keep doing it.
Reply With Quote Quick reply to this message
  #9  
Old 05-26-2013, 05:35 AM
Compression Ignition Addict
 

Join Date: Jul 2012
Location: bel air, maryland
Posts: 1,917
Thanks: 4
Thanked 26 Times in 20 Posts
Feedback Score: 1 reviews
He needs to replace the injectors period..... There should be no reason to have to take apart the truck and take all the injectors out to clean the spool valves(after one measly year to boot)... Screw that, you pay big money to have upgraded injectors- they should function correctly too.
Reply With Quote Quick reply to this message
  #10  
Old 05-26-2013, 06:12 AM
Banned
 

Join Date: Mar 2013
Location: 210a Maple Ave
Posts: 799
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Warrens web page says 90 day warranty on rebuilt cores injectors, and 1 year warranty on new injectors.
Which did you have?
Also those are large injectors are you running a regulated return?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:22 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors