Limp Mode - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-20-2013, 04:37 AM Thread Starter
Compression Ignition Addict
 
Pistolgrip426's Avatar
 
Join Date: Aug 2011
Location: Ottawa,canada
Posts: 281
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Limp Mode

I had a bad coolant leak under the intake manifold,due to an inferior designed j tube,used for egr delete,the hold down let it wiggle around thus wearing out the o ring. anyhow ordered and installed a better billet pce. from Performance machine. leak fixed, replaced turbo and pedestal,and all the aftercooler piping and air cleaner assembly. truck fired right up,idles fine and no power ?, won't stall in gear,but won't move out of the shop,ran perfect into the shop,and actually has had no issues for month's, 04.5 6.0,f-550,4x4,auto trans,FICM 48.5-49 v while running, any ideas ? All I did was the turbo and pedestal removal,to access the j tube and the underside of the intake to re and re with new tube,and re-assemble,just a basic 4 hour job ,

2004.5 F-550,4x4,6.0,auto,CTS monitored,
Performance Machine egr delete,caterpillar elc,blue spring, CTS Monitor,flat plate agm batteries,K8 code, super tow pkg. (4.88),twin line recovery wrecker.

Last edited by Pistolgrip426; 05-20-2013 at 05:18 AM.
Pistolgrip426 is offline  
post #2 of 3 Old 05-20-2013, 04:52 AM Thread Starter
Compression Ignition Addict
 
Pistolgrip426's Avatar
 
Join Date: Aug 2011
Location: Ottawa,canada
Posts: 281
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
also note,I have 2 brand new agm batteries,and she puts out 13.8 volts at idle,alternator is new,

2004.5 F-550,4x4,6.0,auto,CTS monitored,
Performance Machine egr delete,caterpillar elc,blue spring, CTS Monitor,flat plate agm batteries,K8 code, super tow pkg. (4.88),twin line recovery wrecker.
Pistolgrip426 is offline  
post #3 of 3 Old 05-20-2013, 11:53 AM Thread Starter
Compression Ignition Addict
 
Pistolgrip426's Avatar
 
Join Date: Aug 2011
Location: Ottawa,canada
Posts: 281
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Fixed problem, good to go

2004.5 F-550,4x4,6.0,auto,CTS monitored,
Performance Machine egr delete,caterpillar elc,blue spring, CTS Monitor,flat plate agm batteries,K8 code, super tow pkg. (4.88),twin line recovery wrecker.
Pistolgrip426 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome