Stumped HELP - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-10-2013, 09:23 PM
Powerstroke.org Rookie
 

Join Date: Aug 2009
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Stumped HELP

Im stumped i have a 03 6.0. Last fri i got about halfway to work and sitting at a stop light i noticed it started idling rough and sounded alot deeper and when i would take off seemed like lack of power. when i left work same thing except steadily got worse till i almost couldnt get it pulled into a gas station as i had it floored or nothing wanted to stall. poped hood i wasnt puking coolant nothing looked out of place oil on dipstick looked fine. finally i took the degas bottle cap and alot of pressure seemed to relese. right after i put cap back on the truck started idling fine and drove through a near by parking lot ran like normal the whole time never had a rise in temperature. ran fine the two times this week drove it untill tonight and it started the same thing with out the wanting to stall butthis time the engine temp went up to high but egt's were where they normaly are. no codes, no coolant puking from degas bottle, i have noticed past few months under driver side floormat it stays damp even after drying it out. im completely stumped PLEASE help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-11-2013, 05:12 AM
Premium Member

 

Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 2,946
Thanks: 6
Thanked 80 Times in 74 Posts
Feedback Score: 0 reviews
What is the HPO pressure doing when this is happening? Since it seems so severe, but recovers, it might be an IPR issue. However, since you didn't give us much info to work with, it could be caused by a variety of issues: FICM, fuel, etc.
Reply With Quote Quick reply to this message
  #3  
Old 05-11-2013, 05:28 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,241
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
sounds to me like you have more than one issue , idling and running funny issue sounds like ipr or icp problem, puking coolant issue may be an egr cooler or head gaskets

in my opinion this truck needs some one to spend some time with a scanner , monitoring icp voltage , ipr percentages , what codes are in system if any , monitor ect and eot temps
Reply With Quote Quick reply to this message
  #4  
Old 05-11-2013, 08:50 AM
Powerstroke.org Rookie
 

Join Date: Aug 2009
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
soory for lack of info i been waiting on a buddy of mine to hook it up to his computer. until then im in the dark myself its not puking matter of fact thats kinda what has me stumped when i took the degas bottle cap off it seemed like there was to much pressure built up but before i took the cap off it wasnt hissing or anything. twice when ive started it it started and was idling way down in the high 400rpm low 500rpm then pick up after a few seconds but still idle rough. it does seem like ive lost a small amount of coolant but there doesnt seem to be any coolant in my oil and it isnt coming from my tail pipe that me or my buddy or dad have noticed while watching it. at first we were thinking hpo problem but when the engine temp went way up right to the verge of overheating made me think more on lines of egr cooler or head gaskets or something along those lines. i have noiticed my driver side floor board being damp and was wondering if i got a blockage in my heater core and leak that could be causeing it? and im not throwing any codes on a basic scanner but when i get the computer hooked up i think ill have a better idea what going on
Reply With Quote Quick reply to this message
  #5  
Old 05-11-2013, 08:57 AM
Premium Member
 

Join Date: Sep 2011
Location: St.Louis Mo
Posts: 1,567
Thanks: 1
Thanked 6 Times in 6 Posts
Feedback Score: 2 reviews
maybe your ficm is at an extreme low voltage.. honestly it could be a million things let us know some numbers your buddy gets with his scanner.
Reply With Quote Quick reply to this message
  #6  
Old 05-11-2013, 08:53 PM
Premium Member

 

Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 2,946
Thanks: 6
Thanked 80 Times in 74 Posts
Feedback Score: 0 reviews
Since your cap held the pressure, it is unlikely you have a coolant/headgasket problem. As long as the coolant returns to the same level (cold), you don't have a leak to find. The monitor or diagnostic tool should give the tell-tale info to figure out cause of the low idle.
Reply With Quote Quick reply to this message
  #7  
Old 05-13-2013, 06:06 PM
Powerstroke.org Rookie
 

Join Date: Aug 2009
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
well i did a block test today and it come back all good but i did notice when i added some coolant while it was running and turned the heat on to circulate it completely that it got a little rougher idling but would level out (but still idle rough) when i turned the heat off. still havent put it on the computer yet. but i had a few buddies tell me that it might be my heater core that would be where the damp driver side floor board and slight coolant loss would be coming from so before i go jumping to far into things im gonna try the heater core and a new thermostat and flush the coolant system and delete the egr see what happens
Reply With Quote Quick reply to this message
  #8  
Old 05-15-2013, 03:37 PM
Member
 

Join Date: Jul 2009
Location: Golden Valley
Posts: 70
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I would think you would be smelling coolant in the cab if your heater core is shot.
Reply With Quote Quick reply to this message
  #9  
Old 05-19-2013, 09:29 AM
Powerstroke.org Rookie
 

Join Date: Aug 2009
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just a update but finally yesterday figured out it was the fuel pump. Put the new one in starts right up runs good and my buddy data logged when we took it for a test drive and everything checked out good but I do still know the heater core is leaking so that and some other stuff going on next weekend
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:47 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors