2006 F250 6.0 Diesel Replaced Heads and ran for an hour, now won't start - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-05-2013, 08:46 PM
Powerstroke.org Rookie
 

Join Date: May 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation 2006 F250 6.0 Diesel Replaced Heads and ran for an hour, now won't start

I replaced the heads on a 2006 F250 6.0 Diesel, put it all back together and started it up. It ran great for about an hour , then it started cutting out. I killed it and it took a little bit to restart it, spinning over and over to get it to run, this took place several times. The engine died and now it will not start. I keep getting codes P2284 and P2290. Any ideas what could be causing this problem?? When you turn the key on the fuel pump comes on and the injectors pulse, but when the pump shuts off the injectors quit pulsing. When you try to start vehicle the injectors still won't pulse. Could this be the cam or crank sensor? The tester reads 40, Idk if this is enough volts to open the injectors.......

Last edited by frogjaw; 05-05-2013 at 09:02 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-05-2013, 08:47 PM
Winning DUHHH


 

Join Date: Sep 2010
Location: Sunrise Beach, MO
Posts: 2,357
Thanks: 0
Thanked 10 Times in 10 Posts
Feedback Score: 0 reviews
Are you getting com between the obd2 port and ECU? Sounds like something chaffed or rubbed through


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #3  
Old 05-05-2013, 08:59 PM
Powerstroke.org Rookie
 

Join Date: May 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It is communicating. This all started after I changed the head gaskets, I keep getting ICP codes........ but when I unhook the ICP it still won't start so I don't think that's the problem......
Reply With Quote Quick reply to this message
  #4  
Old 05-05-2013, 09:01 PM
Winning DUHHH


 

Join Date: Sep 2010
Location: Sunrise Beach, MO
Posts: 2,357
Thanks: 0
Thanked 10 Times in 10 Posts
Feedback Score: 0 reviews
Hmm, no start either way?

Check your harnesses for chaffed


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #5  
Old 05-05-2013, 09:55 PM
information regurgitator
 

Join Date: Dec 2010
Location: Epping, NH
Posts: 5,943
Thanks: 20
Thanked 185 Times in 172 Posts
Feedback Score: 0 reviews
Pull the IPR and check the screen for trash.
Reply With Quote Quick reply to this message
  #6  
Old 05-06-2013, 07:03 AM
Powerstroke.org Rookie
 

Join Date: May 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I located the IPR, the connector or maybe even the whole housing seems really loose. Is this normal?
Reply With Quote Quick reply to this message
  #7  
Old 05-06-2013, 10:55 AM
Run in to my fist!
 

Join Date: Jun 2010
Location: Douglassville, PA
Posts: 1,302
Thanks: 7
Thanked 16 Times in 16 Posts
Feedback Score: 0 reviews
Yes its normal. Thats just the coil on the armature. Some are a tighter fit than others. As NYC F-350 suggested, pull the IPR and inspect. 2290 is a low ICP code so that steers you in the direction of a HPO leak somewhere
Reply With Quote Quick reply to this message
  #8  
Old 05-07-2013, 10:17 AM
Powerstroke.org Rookie
 

Join Date: May 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I pulled the IPR off to inspect it, the screen was broken and I found two wires touching under the turbo...... It runs GREAT now!! Thanks for all the help guys!!
Reply With Quote Quick reply to this message
  #9  
Old 05-07-2013, 06:26 PM
Member
 

Join Date: Apr 2013
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by frogjaw View Post
I pulled the IPR off to inspect it, the screen was broken and I found two wires touching under the turbo...... It runs GREAT now!! Thanks for all the help guys!!
This site rocks!
Reply With Quote Quick reply to this message
  #10  
Old 05-08-2013, 07:41 AM
Winning DUHHH


 

Join Date: Sep 2010
Location: Sunrise Beach, MO
Posts: 2,357
Thanks: 0
Thanked 10 Times in 10 Posts
Feedback Score: 0 reviews
Glad she's running!


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:57 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors