Beer delivery van issues- I thought EGR, but now runs fine. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-29-2013, 03:50 PM
Powerstroke.org Rookie
 

Join Date: Jan 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Beer delivery van issues- I thought EGR, but now runs fine.

On Friday our '05 E-350 extended started bucking hard and blowing a lot of white smoke out the exhaust. Thankfully it happened at the end of the day as the driver was heading back to the brewery. I limped it back the last half mile. This was probably dumb, and no I had not started drinking when I made the decision to drive the last half mile with a cloud of white smoke trailing me.

Last Monday fluids were checked. Coolant was on the low end, but above min. On Friday after the getting it back to the brewery it needed a full gallon to get back to the min mark.

This morning I come in to do the BPD test to see if the issue is the EGR or the head gaskets. Strangely, the van runs fine. It ran like it was suppose to. After warming up the motor, I drove it around for a bit and added more throttle until I was WOT, and all was good. When I performed the BPD test I saw very few bubble when the wiring plug was both connected, and disconnecting.

What in the hell is going on? Do I have an EGR cooler leak that plugged itself when the engine cooled over the weekend? If I have full power do I rule out headgasket issue, and assume EGR cooler? Is it possible to have water in the fuel, that is getting injected into the cylinders?

Thanks for your help.

Mike McGovern
Austin Beerworks,
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-30-2013, 03:54 PM
Powerstroke.org Rookie
 

Join Date: Jan 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Any help or been there done that's would be greatly appreciated. Do I just assume the EGR cooler is shot, and spend a couple of grand on a Bullet Proof Diesel EGR cooler and oil cooler, or is there a chance something else cause the white smoke and bucking issues?

Mike
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
egr, egr cooler

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:19 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors