FICM going bad? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 04-11-2013, 02:20 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
FICM going bad?

I have a 2006 6.0 with some more basis mods like exhaust, egr delete, and a sct tuner. After the egr delete was installed it started making a light buzzing or vibrating when you first give it power after a start. The noise is getting a little louder and now it blows bluish white smoke when it's warming up. It's slowly getting low on coolant so I have topped it off. It will make the noise after each time you turn it and only the first time it seemed to be worse in the cold.
What should I do?
Check the coolant psi?
Bigred178 is offline  
post #2 of 3 Old 04-11-2013, 02:28 PM
Fill it up again Dummy
 
mhatlen's Avatar
 
Join Date: Sep 2012
Location: Central Valley, California
Posts: 2,080
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 113 Post(s)
Thanks: 30
Thanked 100 Times in 89 Posts
Feedback Score: 0 reviews
Yea that would be a good place to start. Did you do a complete delete ?


2006 F250 LARIAT CCSB 4X4: Edge CS2, ARP Studs, O-Ringed Heads, X4 PHP 65 HP Custom Tow Tune, Atlas40 Ficm Tune, CAT EC-1 Coolant, IPR Coolant filter, Fass-125, turbo-back SS 4" pipe, Corsa muffler, 6.4 Banjo's, 6.4 starter,DC Power 270 amp alt, 2/0 cables, Die Hard Platinum AGM, 7" lift w: Icon Progressive Coil Springs, 2008^ Carli/Deaver rear springs on fatty-daddy 38/15.50/18 Toyo's
mhatlen is online now  
post #3 of 3 Old 04-11-2013, 02:40 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yea it was the delete kit with the up pipe
Bigred178 is offline  
Reply

Tags
6.0 , bad noise , coolant , egr delete , ficm

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome