Low on power - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 04-08-2013, 12:31 PM Thread Starter
Powerstroke.org Rookie
Join Date: Nov 2012
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Low on power

I have a 2004 6.0 and recently it started acting up on long trips. After you run it for a while it will start to run rough and lack power. I'll have to floor at a stop light and it will barley get enough power to get going then the turbo kicks in and it takes off. It doesnt seem to smoke at all when this happens. I thought it might be the fuel filters so I replaced those but that didnt solve the problem. my next guess is that I'm gonna have to install an EGR delete but I'm not sure if that is the solution to my problem or if that might only be one part to my solution. Wondering if anyone had any input.

Thanks in advance,


2004 F250 CCSB SRW Lariat
K&N Intake
MBRP 4" Straight Pipe Turbo Back
EGR Delete
ARP Studs
JL Audio C2-570x
Black Harley lights
DDM tuning 55w 6000k headlights and fog lights
Recon Lighting third brake light (smoked)
jtpowerstroke is offline  
Sponsored Links
post #2 of 3 Old 04-18-2013, 06:56 PM
Premium Member
Join Date: May 2011
Location: Lehi, Utah
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Ever figure it out? My '04 acts similarly, low power then all of a sudden the turbo kicks in. I've been thinking it's sticky vanes in the turbo but they were allegedly cleaned last year.
tomshane is offline  
post #3 of 3 Old 04-18-2013, 09:40 PM
Join Date: Jan 2011
Location: Binghamton, NY
Posts: 65
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
pull ebps tube (driver side exh. manifold )and sensor, looks almost like a coolant temps sensor with a brake line from the exh. manifold to sensor base. Mine was almost entirely plugged with soot (at 60k ish i dont remember exactly) and acted similarly to what you are describing.

04 -rclb
RCD EGR Delete
Sctx3 with tunes from Vivian
Xdp coolant Filter
Global charge coolant
MarkBart is offline  
Sponsored Links

egr delete, no power

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome