6.0 loses power - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-04-2008, 05:15 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy 6.0 loses power

I have a 2005 F250 about 2000 miles ago it would be going down the road and then lose power when this happened there was a fog of white smoke coming out the exhaust i mean you couldnt see behind the truck ....when i shut it off and restarted it ,it ran fine ,I was unsure of what to do so being the oil was due i changed it and the fuel filters as well,it ran fine for the 2000 miles and then on the 3 hour drive to the airport at 3am I had to turn it off and restart it honestly 25-30 times my wifes return drive after dropping me off was just as aggravating as the truck would lose all power ,maybe run 30 mph and blow clouds of white smoke out ,it seemed like if you held the speed,rpm,throttle at the same speed it would be ok but when you had to slow down or speed up most of the time thats when it would occur the truck has almost 98,000 miles on it and it has only let me down once before when the hpop got a leak or something and shut itself off......any help or hints or ideas would be appreciated as my local dealer is just about worthless as far as service goes ,Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-04-2008, 08:12 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: Wasco, CA
Posts: 433
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm curious so here's a
Reply With Quote Quick reply to this message
  #3  
Old 02-05-2008, 02:52 AM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like it could be bad injector(s).
Reply With Quote Quick reply to this message
  #4  
Old 02-06-2008, 03:17 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Took it to a different dealer and they say its the egr valve waiting on part today,they first said probably turbo as every single one they have sold has been in for a new turbo,they said that mine must be a good one if its got 98,000 on it and only 2 problems(egr and at 60,000 HPOP),all I know is I want it running well enough to sell cause I dont want to buy a new turbo or injectors for it so it will be for sale very soon.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:00 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors