6.0 loses power - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 02-04-2008, 05:15 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2007
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Unhappy 6.0 loses power

I have a 2005 F250 about 2000 miles ago it would be going down the road and then lose power when this happened there was a fog of white smoke coming out the exhaust i mean you couldnt see behind the truck ....when i shut it off and restarted it ,it ran fine ,I was unsure of what to do so being the oil was due i changed it and the fuel filters as well,it ran fine for the 2000 miles and then on the 3 hour drive to the airport at 3am I had to turn it off and restart it honestly 25-30 times my wifes return drive after dropping me off was just as aggravating as the truck would lose all power ,maybe run 30 mph and blow clouds of white smoke out ,it seemed like if you held the speed,rpm,throttle at the same speed it would be ok but when you had to slow down or speed up most of the time thats when it would occur the truck has almost 98,000 miles on it and it has only let me down once before when the hpop got a leak or something and shut itself off......any help or hints or ideas would be appreciated as my local dealer is just about worthless as far as service goes ,Thanks
madmiketoofiddy is offline  
post #2 of 4 Old 02-04-2008, 08:12 PM
Compression Ignition Addict
 
wtprez's Avatar
 
Join Date: Nov 2007
Location: Wasco, CA
Posts: 433
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I'm curious so here's a

Rodney

2005 F350 SRW 4X4 Lariat CC

Leveling Kit~ARP Studs~SCT Livewire-DJ's Tunes~4" Turbo Back Exaust~Banks Techni-Cooler~Mag-Hytec Diff & Trans Covers~Weld Racing Commando Rims~Mickey Thompson Baja ATZ LT325/60R18 Wheels~Air Bags & Compressor~55 Gal Diesel Tank in stock location~Pace Edwards Roll Top Bed Cover~40 Gal Gas Station in Bed for all my toys (Long Travel Rhino, 2 Raptor 700's, 2 FX High Ouput Waverunners, and a 24' Aqua Patio Pontoon Boat)
wtprez is offline  
post #3 of 4 Old 02-05-2008, 02:52 AM
Powerstroke.org Rookie
 
Jarrett's Avatar
 
Join Date: Jan 2008
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Sounds like it could be bad injector(s).

-1970 Chevy K20 6'' lift, 35'' General M/T's,NA 496CI Iron heads, pump gas, 660FWHP 11.50's@114MPH

-03 GMC 1500, RC,SB,4X4, Trick Front Mount T76(Waiting for track to open)

-07 GMC 2500HD, EX,SB,4X4, STD PPE 90HP, 13.71@98MPH, @5800' elevation(225HP) stock intake & exhaughst.
Jarrett is offline  
post #4 of 4 Old 02-06-2008, 03:17 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2007
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Took it to a different dealer and they say its the egr valve waiting on part today,they first said probably turbo as every single one they have sold has been in for a new turbo,they said that mine must be a good one if its got 98,000 on it and only 2 problems(egr and at 60,000 HPOP),all I know is I want it running well enough to sell cause I dont want to buy a new turbo or injectors for it so it will be for sale very soon.
madmiketoofiddy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome