Bad injectors? rev-x fix? rough start - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-18-2013, 05:23 PM
Powerstroke.org Rookie
 

Join Date: Oct 2011
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bad injectors? rev-x fix? rough start

2004 6.0 227,000 miles
-use rotella oil
-Full EGR delete
-bully dog programmer/scan gauge II
-fuel pressure holds at 60psi
-FICM 47.5-48.5
Batteries good voltage 13.5v
-as far as I know dont think the injectors have been replaced.

When cold, starts fine but runs really rough for a min or two, but needs at least 10 mins to warm up otherwise there is no power when trying to drive. Iv been running the rotella because of the high milage. I was thinking about running REV-X to see if it helps. I have also read that synthetic oil helps the injectors but what about with my high milage?

I show no codes or misfires. is it possible the glow plug(s) are bad?
I just don't really feel like spending 3K on injectors right now
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-18-2013, 05:45 PM
Premium Member

 

Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 3,059
Thanks: 6
Thanked 87 Times in 81 Posts
Feedback Score: 0 reviews
Glow plugs only run for the pre-start start phase. The low power is probably a real dirty EGR stuck open. High milage on the injectors will not be cured by a thicker oil. Leaky seals like thick oil, injectors hate it.

If you have stiction, RevX may help but, the fix in my sig works.
Reply With Quote Quick reply to this message
  #3  
Old 03-18-2013, 05:51 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Re: Bad injectors? rev-x fix? rough start

What is your ficm volts cold cranking/running, and battery voltage cold cranking? An oil change to rotella t6 is alot cheaper than injectors and will only help, not hurt your truck.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #4  
Old 03-20-2013, 04:10 AM
Powerstroke.org Rookie
 

Join Date: Oct 2011
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
When cold cranking My scan gauge says the volts are only 11.2 how can that be? But then they slowly climb. And my Ficm says 47.5 and then right to 48. I checked my batteries and the tester says they are good. And my running volts are around 13.0-13.5. With accessories on and idling around upper 12's
Reply With Quote Quick reply to this message
  #5  
Old 03-20-2013, 05:58 AM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Re: Bad injectors? rev-x fix? rough start

Quote:
Originally Posted by CTerry View Post
When cold cranking My scan gauge says the volts are only 11.2 how can that be? But then they slowly climb. And my Ficm says 47.5 and then right to 48. I checked my batteries and the tester says they are good. And my running volts are around 13.0-13.5. With accessories on and idling around upper 12's
11.2 v is because the glowplugs are lit. That reading is actually good. Your ideling voltage is a bit low, imo. As suggested, pull your egr and clean it. Switch to rotella t6, and try rev-x or archoil if the oil doesn't clear it up. Make sure you are using motorcraft or racor filters with an oem cap.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #6  
Old 03-20-2013, 11:10 AM
Powerstroke.org Rookie
 

Join Date: Oct 2011
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have egr delete. And the synthetic oil with revx should help?even though I have 225k on the motor with slight leakage ?
Reply With Quote Quick reply to this message
  #7  
Old 03-20-2013, 11:31 AM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Re: Bad injectors? rev-x fix? rough start

Quote:
Originally Posted by CTerry View Post
I have egr delete. And the synthetic oil with revx should help?even though I have 225k on the motor with slight leakage ?
Yes synthetic, is not a problem on high mileage engines. Urban legend..... I think most of us have an oil leak of some sort on our engines. Bed plate or rear main. Rev-x it's worth a try after you try the synthetic. Alot of us have had great results with the rotella t6.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:26 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors