Over boost - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-10-2013, 08:49 PM
Compression Ignition Addict
 

Join Date: Dec 2011
Location: Denton,TX
Posts: 197
Thanks: 65
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
Over boost

Guys I need advice. I've got an 06' F250 with 110K on it. I've got an over boost issue no matter the program. I've got and SCT TSX and thought it was a program issue. So I returned it to stock with no avail. I've swapped the vgt solenoid and upgraded the oil feed tube to the solid line. Not sure if it's the EPS, the MAP sensor, or a flash issue. I'm getting like 11psi at 70mph. It sounds like a Jake brake on deceleration and the boost numbers never go to negative at idle like they did before the issue. Help!!

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-11-2013, 06:07 AM
Compression Ignition Addict
 

Join Date: Jul 2011
Posts: 267
Thanks: 8
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
I'd refurbish the turbo as soon as you can or you'll have ARP's in your sig. like me!
Reply With Quote Quick reply to this message
  #3  
Old 03-11-2013, 11:15 AM
Compression Ignition Addict
 

Join Date: Dec 2011
Location: Denton,TX
Posts: 197
Thanks: 65
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
Re: Over boost

Already done 3 weeks ago. It wasn't bad at all. Here's an after pic.

Sent from AutoGuide.com Free App
Attached Thumbnails
Over boost-1363025675626.jpg  
Reply With Quote Quick reply to this message
  #4  
Old 03-11-2013, 05:07 PM
Compression Ignition Addict
 

Join Date: Jan 2013
Posts: 321
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Was the unison ring installed correctly and how much was it worn?
Reply With Quote Quick reply to this message
  #5  
Old 03-11-2013, 08:28 PM
Member
 

Join Date: Jan 2013
Location: st.louis
Posts: 51
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Did you have any rust in the turbo? any pitting? I have had mine apart too and cleaned every nook and cranny and it still sticks! time for a new turbo I guess!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:24 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors