CEL, Power loss, low MPG, Dealer suggests Clean Turbo 2 times in 6k miles - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-10-2008, 05:52 PM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
CEL, Power loss, low MPG, Dealer suggests Clean Turbo 2 times in 6k miles

05 F350 6.0 Diesel, stock, 30K miles.. Twice in last 7k miles my CEL light has come on and I immediately notice a loss in power when pulling a trailer (small trailer, less than 5k lbs) and my MPG go down from an average of 14MPG to 10MPG or less while pulling the trailer or empty. Took it in the first time and dealer said they replaced some valve (donít remember what) and because of a tech bulletin they also cleaned the turbo.. Everything came back Ok and about 6K miles later the same thing happened. Took back to dealer and they said no problem just cleaned the turbo and everything is fine now. I havenít gotten it back yet but wanted to post here to see if others are having similar problems or have a possible solution. On the first go around I changed the fuel filters before taking to dealer to see if that was problem, It wasnít but they are now fresh. My warrantee expires in just a few months and if this is a problem I want to address it before the warrantee expires. It is also a pain in the rear to take this to the dealer so even though they have fixed it both times I want to find and address the root of the problem.

Any help or advice would be appreciated
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-10-2008, 07:36 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Obviously get your truck serviced asap but remember you get 100k warranty on the engine. So even if it doesn't get fixed the first time don't be afraid to take it back.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:38 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors