2006 E450 problem - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-06-2013, 02:38 PM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2006 E450 problem

06 E450 6.0l powerstroke

Problem: Starts fine and runs great and drives great I guess after 20 min of driving or sitting it stalls out. Now you turn the key right after it stalls and it
flashes right up and runs great for about 20min again and stalls out etc....

I have otc genisys and have scaned and tested and the only codes that I have found were: P2290 , B1318 , B1352 , B1360
ICP good
PCM good
Rpm signal with scantool good
inj buzz test good
glow plug test good

This thing has a clean bill of health every thing checks out good and Iam not finding the problem I am thinking that it must be electrical all fuse good.
The fuel tank has been replaced by the dealer.

Also checked no out standing TSB or Recalls.
I did record the problem with my genisys and looking over every thing in playback mode hoping .
find the cause of the problem as it happened.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-06-2013, 05:10 PM
Vintage Nakamichi Powered
 

Join Date: Sep 2012
Location: Elk Grove, California
Posts: 1,357
Thanks: 9
Thanked 40 Times in 34 Posts
Feedback Score: 0 reviews
Check all 3 plugs going into your FICM a loose one can do it.

Also take a close look at the ICP on pass valve cover: tight/no oil ect.
Reply With Quote Quick reply to this message
  #3  
Old 03-06-2013, 05:29 PM
Powerstroke Techie

 

Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,336
Thanks: 23
Thanked 83 Times in 74 Posts
Feedback Score: 4 reviews
P2290 is a weird code but it could be related to your problem. Is the van lacking power at all? Is it hard starting or long cranking ever? You may have an STC fitting or IPR concern. What does the oil look like? Has it been changed recently? Oil aeration can cause some weird concerns related to ICP


ALSO econolines have far more engine harness issues than the f-series. Without really knowing a whole lot I would also suspect a harness issue causing cam or crank signal interference
Reply With Quote Quick reply to this message
  #4  
Old 03-07-2013, 07:56 AM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No lack of power at all
No long cranking when it stalls turn the key flashes right up
even if its cold in the morning wait for the gp to warm up starts right up.
Yes the oil has been changed and is full done by the dealer.

Thank you for your input and I will check the 3 plugs to the FICM.
I have been on this now 4days straight 8hrs a day ready to go nuts.

Mark.
Reply With Quote Quick reply to this message
  #5  
Old 03-07-2013, 09:24 AM
Premium Member


 

Join Date: Aug 2012
Location: Fort Knox, KY
Posts: 251
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check the ground strap from the FICM to the intake manifold, a loose ground strap could cause the same symptoms.
Reply With Quote Quick reply to this message
  #6  
Old 03-08-2013, 09:29 AM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well I hope get back on it today and will post what I find out. Thanks for the info
and will check every thing out.

Thank you. Mark.
Reply With Quote Quick reply to this message
  #7  
Old 03-08-2013, 11:47 AM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok when sitting and changing the rpm between 1000 and 2000 I can hear the turbo.
But when I take my foot off and let the RPM drop every thing will be quite for a sec or two, That is when it wants stall not all the time though so I tried putting my foot back on the pedal to give it gas and didn't stall out.

Thanks Mark.
Reply With Quote Quick reply to this message
  #8  
Old 03-09-2013, 01:54 PM
Powerstroke Techie

 

Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,336
Thanks: 23
Thanked 83 Times in 74 Posts
Feedback Score: 4 reviews
I'd be looking at the STC fitting. It may be on it's way out. They don't take too kindly to revving when they're starting to seperate
Reply With Quote Quick reply to this message
  #9  
Old 04-03-2013, 07:10 PM
Compression Ignition Addict
 

Join Date: Oct 2008
Posts: 637
Thanks: 0
Thanked 7 Times in 7 Posts
Feedback Score: 0 reviews
Have an 05 E450 with same problem, idling it just slows and quits you can tell when it's going to stop. Just got the truck $1250.00. New fuel filters, old ones looked good, new lift/fuel pump, new batteries & cleaned connections. Still need to clean connections at fuse/relay box. Ran rough until air worked out, now runs smooth, still just up and quits. Will check ground for ficm & connectors tomorrow. Oil at cam sensor wires? Truck has 252k miles with fairly new trans. Anyone have any other ideas. Thanks. Oh I also have an F350 4x4 6.0L with 176k soon to get the full treatment, oil cooler, egr delete, studs, ect. Great truck never been opened, just maintained. AMSOIL.
Reply With Quote Quick reply to this message
  #10  
Old 04-04-2013, 06:47 AM
Premium Member


 

Join Date: Aug 2012
Location: Fort Knox, KY
Posts: 251
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Need to check your ICP and IPR readings, sounds like a HPO leak, or weak pump.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:10 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors