Poor performance since egr aftercooler being replaced by dealer - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 02-26-2013, 05:22 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Poor performance since egr aftercooler being replaced by dealer

I have a 06 king ranch dually with 6.0. When I got it i was getting 17 to 19 on the hi-way and 15 around town. At 64000 I started blowing white smoke and lost power. Sent it to the dealer they replaced the EGR cooler, heads, ect. I got it bad and I lost 4 to 5 miles/gal, it begain to get harder to start and now it runs rough and bucks around 50 miles/hour. The dealer keeps saying there is nothing wrong. I asked if they check and balanced the injector, - it wound cost to much. Any ideas what it is and a fix?

Last edited by Northeastrich; 02-26-2013 at 05:26 PM. Reason: missing info
Northeastrich is offline  
post #2 of 3 Old 02-26-2013, 06:39 PM
Fill it up again Dummy
 
mhatlen's Avatar
 
Join Date: Sep 2012
Location: Central Valley, Sierra Mountains, California
Posts: 2,222
Thanks: 36
Thanked 107 Times in 96 Posts
Mentioned: 6 Post(s)
Quoted: 155 Post(s)
Feedback Score: 0 reviews
Check your ficm output and ICP pressures.


2006 F250 LARIAT CCSB 4X4
ARP Studs, O-Ringed Heads
X4 PHP 65 HP Custom Tow Tune
Atlas40 Ficm Tune
CAT EC-1 Coolant, IPR Coolant filter
Fass-125 to a Adjustable Pressure Reg.
Turbo-back SS 4" pipe, Corsa Muffler -7" Tip
6.4 starter, DC Power 270 amp alt
Die Hard Platinum AGM all 2/0 Cables
7" lift w: Icon Progressive Coil Springs
2008 up Carli/Deaver rear springs
All riding on some Fatty-Daddy 38/15.50/18 Toyo's
mhatlen is offline  
post #3 of 3 Old 02-26-2013, 06:42 PM
Mod Newbie

 
dhanna6powerstroke's Avatar
 
Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 13,156
Thanks: 6
Thanked 142 Times in 134 Posts
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
Feedback Score: 2 reviews
I'll bet money they reflashed your PCM while it was in the shop. That would explain your mileage loss.

dhanna6powerstroke is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome