Edge Juice Problem - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-21-2007, 06:06 AM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Edge Juice Problem

04 Juice problem. Its been working fine then egt was only reading ambient temp and then monitor went out and I got a check engine warning. Engine stalled and when I removed the juice everything was ok. Sent it back for repairs it came back and same problem. Edge said it was s internal edge problem and sent me a new one. Same problem with the new one. Engine code was turbo boost high circuit warning. Anyone have the same problem?????http://www.powerstroke.org/forum/ima...ilies/ford.gif
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-17-2008, 08:54 PM
Serving Our Country!
 

Join Date: Jul 2008
Location: SE, Missouri
Posts: 585
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by safari338 View Post
04 Juice problem. Its been working fine then egt was only reading ambient temp and then monitor went out and I got a check engine warning. Engine stalled and when I removed the juice everything was ok. Sent it back for repairs it came back and same problem. Edge said it was s internal edge problem and sent me a new one. Same problem with the new one. Engine code was turbo boost high circuit warning. Anyone have the same problem?????http://www.powerstroke.org/forum/ima...ilies/ford.gif
I'm having the exact problem but the reading I got from the code was turbo boost low circuit. Talked to edge and they are sending me a new monitor. Did that fix your problem?
Reply With Quote Quick reply to this message
  #3  
Old 07-17-2008, 09:31 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
edge problem

Went back and forth quite a few times with edge. They were very helpful and the problem was finally solved. My truck was "flashed" by the ford dealer for a high pressure oil relay failure. This basically made my trucks computer think it was an 2007 truck. My version or the edge was not compatible with and 07 even thou the truck was really an 04. Edge ended up upgrading me to the newest version (which was quite a bit pricier than the one I had for free), all new components. Working great now, no problems since the changeover quite a while ago.
Reply With Quote Quick reply to this message
  #4  
Old 07-17-2008, 10:31 PM
Serving Our Country!
 

Join Date: Jul 2008
Location: SE, Missouri
Posts: 585
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by safari338 View Post
Went back and forth quite a few times with edge. They were very helpful and the problem was finally solved. My truck was "flashed" by the ford dealer for a high pressure oil relay failure. This basically made my trucks computer think it was an 2007 truck. My version or the edge was not compatible with and 07 even thou the truck was really an 04. Edge ended up upgrading me to the newest version (which was quite a bit pricier than the one I had for free), all new components. Working great now, no problems since the changeover quite a while ago.

How did you find out that it was flashed?
Reply With Quote Quick reply to this message
  #5  
Old 07-18-2008, 05:58 AM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
edge

Actually the truck was runing like crap, no power at all after I got it back from ford. I had taken the edge off to have it in for service. Took it back and they said they had to reset the computer. I guess that was the flash. Did you take your truck in for any service lately?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:54 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors