Diagnosis before taking to dealer: low power, surging when towing, etc. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-18-2007, 06:38 PM
Powerstroke.org Rookie
 

Join Date: Jul 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Smile Diagnosis before taking to dealer: low power, surging when towing, etc.

Hi guys,

I haven't posted much here because I can usually find everything I have questions about by searching the forums. I have a comination of problems that I need some help with. The results of the problems have been a gradual reduction in power and some surging while towing (I miss the power I made when the truck was new!). Only have 53k miles on the truck and its a 2005, boost seems fine, maxing out at about 28-29psi on factory gauge, CEL isn't on, not noticing any coolant loss, filters are changed per Ford specs at the dealer. I recently had it in to have the Y-pipe replaced because it was leaking and the tech told me the turbo looked normal. I talked to him again since then and told him my problems and he said that I probably just need to use some cetane booster. Athough I think thats a good idea it is not the solution to my problems. Here are are some symptoms:

White/blue smoke that happens for between a minute and three minutes every time I start my truck, regardless of the ambient temp. The smoke is now embarassing. Seems to stop after I start driving. EGR valve was very oily (especially the top part of the valve) and sooty when I cleaned it. I had to vacuum out the hole for the EGR valve because it was so nasty (not sure why because I drive the truck pretty hard most of the time). There were chunks of black soot/oil crap inside (I have pictures at work, I will try to upload tomorrow). The EGR valve has been out for cleaning before. Had some serious shudders in second gear during takeoff while towing a 12,000lb trailer a while back. Had to let out of the pedal before boost built up to get it to stop shaking. During the same trip at interstate speeds had much more black smoke than normal during acceleration with boost pressures higher than 20psi; also seemed like power output was reduced. At around 55mph and 1800rpm truck will studder if I am towing anything, even if it isn't heavy, and power feels like it is only at about 60%.

The only work that has been done on the truck is repairs for front seal oil leak, an oil leak on top of the engine (not sure where ), EGR cleaning, recall stuff and computer updates.

I think that I probably have a few different things going on but can you guys give me some input on what you think it might be? I am going to take it in this week but I would like to be able to talk to the tech with some pre-aquired information. Thanks for your help!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-18-2007, 06:49 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
that "oily stuff" in your egr system is probably coolant mixed with the normal carbon residue, ive seen it tons of times before......it sounds to me like you have an EGR cooler going...and your symptoms are the result of that and are being caused by the EGR valve not functioning properly......
Reply With Quote Quick reply to this message
  #3  
Old 12-18-2007, 06:53 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Location: 14 miles northeast of Canadian TX
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sir sounds to me like the egr cooler needs replaced if oily and also if its white somking 9burning a little coolant) at start up I had the same problems for awhile, then I took it off and throw it away peice of junk
Reply With Quote Quick reply to this message
  #4  
Old 12-19-2007, 12:25 PM
Powerstroke.org Rookie
 

Join Date: Jul 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Pictures

Thanks for the help guys. That is what I was thinking.

Here are pics of EGR valve, etc. I also forgot to say that my mileage has dropped from an average of 18 to about 15 and my driving habits haven't changed.

Do you think I should do the EGR delete pipe if I get a new EGR cooler so that I don't ruin the new one? Should I ask them to check out the oil cooler while its in the shop? Thanks!

Jordan
Attached Thumbnails
Diagnosis before taking to dealer: low power, surging when towing, etc.-egr1.jpg   Diagnosis before taking to dealer: low power, surging when towing, etc.-egr2.jpg  
Reply With Quote Quick reply to this message
  #5  
Old 12-19-2007, 07:33 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Location: 14 miles northeast of Canadian TX
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by 05PSD View Post
Thanks for the help guys. That is what I was thinking.

Here are pics of EGR valve, etc. I also forgot to say that my mileage has dropped from an average of 18 to about 15 and my driving habits haven't changed.

Do you think I should do the EGR delete pipe if I get a new EGR cooler so that I don't ruin the new one? Should I ask them to check out the oil cooler while its in the shop? Thanks!

Jordan
Yes sir I would have it all looked at and replaced, and like you said an egr delete pipe afterword would save this problem from happening again. I think anyways
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:41 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors