IPR Valve Bad again?? - Ford Powerstroke Diesel Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 27 Old 02-09-2013, 11:05 AM Thread Starter
Member
 
Ranger5.0l's Avatar
 
Join Date: Sep 2012
Location: Waterloo, IA
Posts: 83
Thanks: 3
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
IPR Valve Bad again??

A month ago i changed out my oil cooler, injectors (warrens 175/stock now), stc fitting, added ipr coolant filter with manifold, BPD FICM, AFE cold air. After all the work it took forever to get it to build ICP pressure but finally fired up. It had a funny idle to it and it turned to be a bad IPR valve. i got that replaced and it ran great...
Now this morning i went out to start it and it cranked longer than normal but fired up and ran fine (slow to build icp according to my cts) did some running around and got on it hard when i let out the truck died and wont restart.. no icp pressure according to the CTS monitor. What would cause it to just quit after a month of driving with no issues?? Could the IPR be bad again and if so what is causing the issue. The one i changed out had stuff all over the screen and it was pushed into the IPR valve.
Ranger5.0l is offline  
post #2 of 27 Old 02-09-2013, 11:31 AM
Serving Our Country!

 
Bluedemon6.0's Avatar
 
Join Date: Apr 2012
Location: Florence sc
Posts: 1,086
Thanks: 8
Thanked 15 Times in 15 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
Send a message via Skype™ to Bluedemon6.0
Re: IPR Valve Bad again??

Sounds like a high pressure oil leak or bad icp. But I'm no pro. Disconnect the icp and see if it goes to a default pressure, it should start. If not I would pull the ipr valve off inspect the screen or do a high pressure leak check.

Sent from my PG06100 using AutoGuide.Com Free App

-Steven

New!! 2015 Mustang ecoboost!!

Sold!!

formally owned:04 6L PSD CCSB
Studs
Egr delete
S&b intake
New dashboss with fuel pressure and egt
Sct Looney by Vivian and Tonywildman xtreme early lock up now php 140x
63.5/88mm 06 turbo with a pmax billet WW2
PHP Atlas 80


My baby-
87 jeep wrangler
350 and 700r4 built by mad dawg transmission
Dyno @ 200hp and 400ftlb at 3100 rpm
On 33s
Bluedemon6.0 is offline  
post #3 of 27 Old 02-09-2013, 12:04 PM Thread Starter
Member
 
Ranger5.0l's Avatar
 
Join Date: Sep 2012
Location: Waterloo, IA
Posts: 83
Thanks: 3
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Unplugged the icp and shows 1000 psi cranking but still no start ....if it is the IPR I have no issue chaning it again but if its only gonna last a month and suck more crap in screen I cant keep chaning it just wondering what could cause this
Ranger5.0l is offline  
post #4 of 27 Old 02-09-2013, 12:12 PM
,,,,,,,,,,,,,,,,,,,,,,,,,
 
ZMANN's Avatar
 
Join Date: Feb 2008
Posts: 15,139
Thanks: 585
Thanked 740 Times in 707 Posts
Mentioned: 62 Post(s)
Quoted: 671 Post(s)
Feedback Score: 0 reviews
I know it sucks but it's not unheard of to go that fast


check it out and if bad do the screen kit

.
.
.
Please donate to DTR Ron's Memorial
https://www.gofundme.com/2464axqr
We Miss you Ronnie
RIP
ZMANN is offline  
post #5 of 27 Old 02-09-2013, 08:46 PM
Powerstroke.org Rookie
 
black haze's Avatar
 
Join Date: Dec 2011
Location: Stouffville
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
usually debrie from the oil cooler replacement gets into it plugging the screen if you chance the screen you shouldnt have the problem again

Blue Spring Kit
6.4 Banjo bolts
home made Coolant Filter
EGR Delete
ELC Coolant
South Bend Clutch (had nothing but bad luck)
Edge Juice With Attitude
4 Gauge Pillar with Boost and Pyrometer. Fuel Pressure and oil Pressure to come
2011 interior door panels
33" General Grabbers
black haze is offline  
post #6 of 27 Old 02-10-2013, 02:53 AM Thread Starter
Member
 
Ranger5.0l's Avatar
 
Join Date: Sep 2012
Location: Waterloo, IA
Posts: 83
Thanks: 3
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thanks for the info guys wasnt aware i could just change the screen out i figured something got past the screen and ruined the valve every time. I'll pull the IPR again and check it out
Ranger5.0l is offline  
post #7 of 27 Old 02-10-2013, 04:51 AM
Powerstroke Techie
 
Join Date: Apr 2012
Posts: 1,866
Thanks: 40
Thanked 51 Times in 51 Posts
Mentioned: 11 Post(s)
Quoted: 68 Post(s)
Feedback Score: 0 reviews
if something got on/into the ipr screen, it went through the pump. possibility that the pump is damaged. pull the ipr and check for any metal debris

the richest ones are not those who have the most, but those who need the least
kaya is offline  
post #8 of 27 Old 02-10-2013, 06:18 AM Thread Starter
Member
 
Ranger5.0l's Avatar
 
Join Date: Sep 2012
Location: Waterloo, IA
Posts: 83
Thanks: 3
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
How do i know if it damaged the pump?

Ranger5.0l is offline  
post #9 of 27 Old 02-10-2013, 06:40 AM
Premium Member

 
twoicebergs's Avatar
 
Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 3,429
Thanks: 8
Thanked 125 Times in 117 Posts
Mentioned: 4 Post(s)
Quoted: 36 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Ranger5.0l View Post
Unplugged the icp and shows 1000 psi cranking but still no start ....if it is the IPR I have no issue chaning it again but if its only gonna last a month and suck more crap in screen I cant keep changing it just wondering what could cause this
Where were you measuring to get the 1000psi? If it was just coming from your Cts, it sounds like your pump took a dump. Your first IPR change was probably the warning shot. If you really do have good ICP then, if your IPR is damaged again, you need to figure out what is the culprit, metal or goo.

Frank
2007 F-250 Lariat Crew. MBM 190/50s,
KC-68 Stage 3 Turbo,
DashBoss/F/P, and a few other goodies
Stiction Problems - Fix it yourself! - http://www.powerstroke.org/forum/gen...ml#post4509754
Want to modify your injectors DIY - http://www.powerstroke.org/forum/6-0...ger-flows.html

Working for Toys
twoicebergs is offline  
post #10 of 27 Old 02-10-2013, 07:57 AM
Powerstroke Techie

 
Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,825
Thanks: 33
Thanked 143 Times in 129 Posts
Mentioned: 0 Post(s)
Quoted: 13 Post(s)
Garage
Feedback Score: 4 reviews
It all depends on how much dirt got down in the reservoir. Knock on wood i've never had one come back from a previous oil cooler replacement but i have seen more than a few IPR screens trashed (and even saw a new metal oil cooler screen with a window busted out and full of dirt) when other people did coolers.

-Matt

Ford Senior Master Tech

2015 F-250 XLT 6.7L

2006 F-250 6.0L SOLD
sinner6.0L is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome