2003 6.0 problem - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-06-2013, 09:57 AM
Member
 

Join Date: Mar 2007
Location: Darby, Montana
Posts: 84
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2003 6.0 problem

Its a F350 2003 6.0.. we bought it used w/ 33,000+ miles and almost 3 yrs old. Everything was good till we heard how bad the turbo was. But what was happening is we lose power on hills towing or not and a weird noise is made. Seems to take forever to get boost and power back. Now we had a rough start problem corrected, they reflashed the brain w/ an upgrade. Our boost power problem was still there. We just installed an upgraded new turbo. Truck still makes that sound. Anyone have any idea's about why the slow spool back up and the weird noise?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-06-2013, 11:40 AM
Powerstroke.org Rookie
 

Join Date: Feb 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2003 6.0 problem

Have you checked for a crack in the Y pipe going to the turbo


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #3  
Old 02-06-2013, 02:04 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Re: 2003 6.0 problem

Check for plugged map sensor hose, loose torn cac boots, exhaust leaks. Did a ford dealer or "6.0 specialist" work on this truck?

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #4  
Old 02-06-2013, 03:42 PM
Member
 

Join Date: Mar 2007
Location: Darby, Montana
Posts: 84
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
This pickup actually belongs to a friend of mine, and I have to wait till she gets off work to relay more info. I am going to have her husband check the things you guys have said so far. Thanks, and I will post more.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:25 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors