Turbo lag??? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 02-03-2013, 05:36 PM Thread Starter
Member
 
MdSuperduty's Avatar
 
Join Date: Jan 2013
Location: Crownsville
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Turbo lag???

So my truck is at 200k+ miles and I've noticed that there's times when I press the skinny to the floor and the motor revs to around 2800+ rpm but doesn't get n go for about 20 secs.... I don't have a programmer but I do have larger injectors (see sig) now when I do this ill be running at about 45-55mph and get on it, seems like its a turd! Any ideas? How often should we pull and clean the turbo and is it tedious to do it?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
03 f-350 6.0l, RCD 90hp injectors,egr delete,blue spring kit, 33" ats,5" exhaust, nothin to special right now
79 bronco 7" lift,38.5x15x15 hawgs,400m ported& polished etc...
MdSuperduty is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 02-03-2013, 07:02 PM
Compression Ignition Addict
 
ford_cummins83's Avatar
 
Join Date: Aug 2009
Posts: 362
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I just did mine at 190 and my unison ring was worn, so it definately wouldn't hurt if you've never done it before.. Have you checked your elbow boot coming off the turbo?

04 king ranch fx4, sct x2, cts monitor, zoodad, cai, 5" exhaust, alligator delete, 6.4 banjo's, blue spring, mtw hybrid w/03 wheel, smoked lights, 2012 bumper, mtx stereo sytem
2012 ford fusion -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ford_cummins83 is offline  
post #3 of 5 Old 02-03-2013, 07:40 PM
Compression Ignition Addict
 
southend's Avatar
 
Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Re: Turbo lag???

Check the map sensor hose and nipple to make sure it's not clogged. Located on the right side of the intake.

Sent from my phone that somebody didn't help me get.

Unfortunately had to Sell my ......2004 KR CC SWB FX4 - Edge insight cts, blue spring upgrade, updated HFCM drain plug, XDP coolant filter, CAT EC-1 rated coolant, Custom Diesel EGR delete, CAT delete, Rotella T6

SEE MY OIL COOLER REPLACEMENT AND EGR DELETE -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
southend is offline  
post #4 of 5 Old 02-03-2013, 08:08 PM Thread Starter
Member
 
MdSuperduty's Avatar
 
Join Date: Jan 2013
Location: Crownsville
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I've never pulled the turbo apart, I've checked the boot and its on good,I haven't checked the map sensor but I do have a cold intake with an open filter, is there a turbo rebuild kit that I need to buy? And also does anyone have a guide on pulling it apart, I don't remember the production date I want to say its either an 06/03 or 09/03 does that make any difference in the turbos?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
03 f-350 6.0l, RCD 90hp injectors,egr delete,blue spring kit, 33" ats,5" exhaust, nothin to special right now
79 bronco 7" lift,38.5x15x15 hawgs,400m ported& polished etc...
MdSuperduty is offline  
post #5 of 5 Old 02-03-2013, 08:25 PM
Compression Ignition Addict
 
southend's Avatar
 
Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Re: Turbo lag???

Quote:
Originally Posted by MdSuperduty View Post
I've never pulled the turbo apart, I've checked the boot and its on good,I haven't checked the map sensor but I do have a cold intake with an open filter, is there a turbo rebuild kit that I need to buy? And also does anyone have a guide on pulling it apart, I don't remember the production date I want to say its either an 06/03 or 09/03 does that make any difference in the turbos?
Tons of info here......http://www.forddoctorsdts.com/articles/

Plenty of videos on youtube. You shouldn't normally need any parts just to remove it and clean it.

Sent from my phone that somebody didn't help me get.

Unfortunately had to Sell my ......2004 KR CC SWB FX4 - Edge insight cts, blue spring upgrade, updated HFCM drain plug, XDP coolant filter, CAT EC-1 rated coolant, Custom Diesel EGR delete, CAT delete, Rotella T6

SEE MY OIL COOLER REPLACEMENT AND EGR DELETE -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
southend is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome