No power... - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-01-2013, 04:08 PM
Compression Ignition Addict
 

Join Date: Aug 2009
Posts: 362
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No power...

Hey guys, I feel like I don't have the power I should have, I'm running Vivian's custom race tune, and mtw hybrid, my stock unison ring took a dump so I bought this hybrid, but without tuning I can get about 5psi and with tuning I don't get more then 17, I checked all my boots, all my exhaust clamps and gaskets and still nothing, when I first put the turbo on I couldn't spool it and found the nipple on my intake to be clogged so I just checked that again and it was still clean.. I'm kinda running out of ideas here and hoping maybe somebody has experienced this before and can point me in a direction.. I also checked my little boot coming of the turbo and it don't have any tears in it
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-03-2013, 05:58 PM
Compression Ignition Addict
 

Join Date: Aug 2009
Posts: 362
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Nobody?? I just replaced the map sensor and still no difference.. What kinda boost are y'all getting with these hybrids?
Reply With Quote Quick reply to this message
  #3  
Old 02-03-2013, 07:18 PM
Premium Member

 

Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 2,958
Thanks: 6
Thanked 81 Times in 75 Posts
Feedback Score: 0 reviews
You should be able to get 25-30 psi depending on what gauge you have. I don't know if you have it, but the stock gauge or OBDll port only show up to 22.9. What is the VGT position doing? EBP partially blocked or leaking? Do you have a leak or bad connection in you up pipes to turbo? What is the back pressure?
Reply With Quote Quick reply to this message
  #4  
Old 02-03-2013, 08:52 PM
Compression Ignition Addict
 

Join Date: Aug 2009
Posts: 362
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm just using my cts, I'm gonna check my ebp tomorrow, I never thought about it, I checked all my connections and everything is tight and clean, no smoke around the connections
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:03 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors