Overheated? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-29-2013, 04:18 AM Thread Starter
Compression Ignition Addict
Jack Lester's Avatar
Join Date: Jan 2013
Posts: 286
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews

I was flushing the coolant on my 6.0 when I added straight water to the system for the second time I drove up the road bout 2 miles when I heard a whistling sound coming from my coolant tank then a this sound when I lifted the hood the water level was ok and not boiling the whistle stopped as soon as I heard the thud. When I pulled the bottom hose off the radiator side of the water was just warm but the block side was quite a bit hotter. Did I do damage? I just had heads done with arp studs. Input please.
Jack Lester is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome