Bad fuel or bad injector or????? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-25-2007, 07:23 AM
Powerstroke.org Rookie
 

Join Date: Nov 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bad fuel or bad injector or?????

I topped off my 6.0L the other morning at Wal-Mart, about 15 miles later the truck started running rough. It got so bad it died on the side of the road. It restarted and continued to run rough then normal and back to rough, max speed would vary from 30-75. When I got home I drained about a gallon of fuel from the filter drain with no water. We changed both filters with a few water particles around the engine mounted filter. I figured this would clear up the issue but it has not. It know runs for the most part ok, but idles very rough if its in drive at a stop light. You guys have any suggestions? I did add quite a bit of fuel supplement after this problem started.

Thanks,

Matt
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-25-2007, 07:43 AM
Jon
Guest
 
Posts: n/a
runs rough

do you smell any gasoline in the samples?
Reply With Quote Quick reply to this message
  #3  
Old 11-25-2007, 08:25 AM
Powerstroke.org Rookie
 

Join Date: Nov 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No, i did not but it did look very yellow....
Reply With Quote Quick reply to this message
  #4  
Old 11-25-2007, 08:30 AM
Desert Shield/Storm Vet

 

Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Diesel has a yellow tint to it. Hmm did the ses light up on the dash?
Reply With Quote Quick reply to this message
  #5  
Old 11-25-2007, 02:56 PM
Powerstroke.org Rookie
 

Join Date: Nov 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no, no lights on the dash either!!!! There was water in the bowl on the engine fuel filter.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:10 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors