6.0 bad injector ? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-24-2013, 02:34 AM
Compression Ignition Addict
 

Join Date: Aug 2011
Location: Ottawa,canada
Posts: 281
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
6.0 bad injector ?

04.5 mota' been running awesome,all of a sudden we get -40*C cold weather,truck ran great yesterday,then all of a sudden idled with a slight miss,got a #1 imbalance code,but runs well under load,just idle,hopeful that it just maybe plugged filter or fuel gelled a bit,added lotsa conditioner and filled it up,before parking it overnite,,,fired right up this morning,still -40,filters are only 1 month old,thinking of changing them again this am, lift pump is about 1 year old,has blue spring,but don't have a fuel press. guage. what ya'all think ?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-24-2013, 07:39 PM
Compression Ignition Addict
 

Join Date: Jul 2012
Location: bel air, maryland
Posts: 1,882
Thanks: 2
Thanked 23 Times in 18 Posts
Feedback Score: 1 reviews
hmmm. Ive never had a failed injector cause i miss at idle... Faulty injects are known for hesitation on accelerating around 1700 to 2000 rpms or the other way at WOT... Usually a miss at idle i would look at the ICP sensor first. But yes in that extreme freaking cold temps an injector could go south.. Just giving you other ideas

Last edited by 04cr450; 01-24-2013 at 07:44 PM.
Reply With Quote Quick reply to this message
  #3  
Old 01-24-2013, 09:57 PM
Banned
 

Join Date: Dec 2012
Posts: 1,048
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I wouldn't make any assumptions that anything is wrong until the weather warms up. Keep in mind, if your engine was 'officially' an International engine, your owners manual would instruct you to run the idle at 1200 rpm minimum, in temperatures below +20 F. (And you are WAY below that!) That cold, gelling is an issue, the spring for your pressure regulator....does it still have the same force at that temperature? I doubt it. You're lucky it even started.....
Reply With Quote Quick reply to this message
  #4  
Old 01-25-2013, 06:51 AM
Compression Ignition Addict
 

Join Date: Aug 2011
Location: Ottawa,canada
Posts: 281
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Lucky it started, ? Lol, wrong! canadian winter prep pkg. is way different than factory, the truck has fuel tank heaters, battery heating pads , and oil pan heater, it fires up at summertime eot and ect temps, fuel here is clear #1 it doesnt gel on city driving trucks, filters are changed every month in winter.,just in case of water intrusion, bluespring is not gonna go below stock spring specs, my tech told me to drive it like a rental and check oil for fuel often, supposed warm up 20* tommorrow, gonna leave it in my shop all wknd. See if she clears up by monday.running fine today, just that small miss at idle,definitely fuel related.
Reply With Quote Quick reply to this message
  #5  
Old 01-25-2013, 12:28 PM
Compression Ignition Addict
 

Join Date: Aug 2011
Location: Ottawa,canada
Posts: 281
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Changed ICP pigtail this aft. Made no difference, sensor is only 3 months old, have 580psi @idle, but getting 2290 code, for long time, ipr is a year old, i don't have any HPO leaks, i don't believe. I do have a nasty driver side up pipe leak. Have a new one in my shop gonna change tommorrow.
Reply With Quote Quick reply to this message
  #6  
Old 01-25-2013, 01:33 PM
Banned
 

Join Date: Dec 2012
Posts: 1,048
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Pistolgrip426 View Post
Lucky it started, ? Lol, wrong! canadian winter prep pkg. is way different than factory, the truck has fuel tank heaters, battery heating pads , and oil pan heater, it fires up at summertime eot and ect temps, fuel here is clear #1 it doesnt gel on city driving trucks, filters are changed every month in winter.,just in case of water intrusion, bluespring is not gonna go below stock spring specs, my tech told me to drive it like a rental and check oil for fuel often, supposed warm up 20* tommorrow, gonna leave it in my shop all wknd. See if she clears up by monday.running fine today, just that small miss at idle,definitely fuel related.
Nice set up! A real necessity I'd say.
Reply With Quote Quick reply to this message
  #7  
Old 01-25-2013, 07:38 PM
Compression Ignition Addict
 

Join Date: Apr 2012
Posts: 1,065
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
probably needs an injector. i mean, it aint unheard of..
Reply With Quote Quick reply to this message
  #8  
Old 01-26-2013, 04:33 AM
Compression Ignition Addict
 

Join Date: Aug 2011
Location: Ottawa,canada
Posts: 281
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
ya,prolly,just never had a 6.0 that would go up and down hills on the cruise @65mph,and never miss a beat, loaded or empty and just miss at idle,they usually just go limp in my experience,lol at least it made me $3k with a bad injector and I didn't have to take it out of svc for 2 days of the cold snap,which is supposed to end today or tonite.
Reply With Quote Quick reply to this message
  #9  
Old 01-26-2013, 08:26 AM
Compression Ignition Addict
 

Join Date: Apr 2012
Posts: 1,065
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
what is the ipr reading at idle with 580 icp? if it's at 85%, i'd say either the pump is weak, the ipr is bad, or you have a bad leak. since the ipr is new-ish, i doubt that. if it starts fine hot, i doubt it's a leak. kinda narrows it down..
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:22 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors