What is my FICM issue?? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-19-2013, 06:35 AM
Powerstroke.org Fanatic
 

Join Date: Dec 2011
Location: ontario(mississauga)
Posts: 122
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What is my FICM issue??

Ok,i have an 06 f250,180,000 kms....my issue is this;when i turn key halfway my Edge insight reads 48v on ficm,batteries 13 v,after cranking my FICM drops to 35-38 volts,but after truck warms up and runs my FICM eventually goes up to the required 48volts......so is my FICM shot?Even though it reads 48v after heating up?Its only after initial start that it drops....oh temps are cold up here,-7 to -20!!!Any advice would be greatly apreciated!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-19-2013, 06:51 AM
Compression Ignition Addict
 

Join Date: Oct 2012
Location: Lorain OH
Posts: 545
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
toast. Send it out to be repaired.
Reply With Quote Quick reply to this message
  #3  
Old 01-19-2013, 06:54 AM
Powerstroke.org Fanatic
 

Join Date: Dec 2011
Location: ontario(mississauga)
Posts: 122
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thats what i figured,guess i had to hear it from someone to make sure!!lol
Reply With Quote Quick reply to this message
  #4  
Old 01-19-2013, 09:24 AM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: port arthur texas
Posts: 3,775
Thanks: 0
Thanked 37 Times in 36 Posts
Feedback Score: 0 reviews
sssshhhhhh the Canadians still think NY is part of canada.
Reply With Quote Quick reply to this message
  #5  
Old 01-19-2013, 12:29 PM
Vintage Nakamichi Powered
 

Join Date: Sep 2012
Location: Elk Grove, California
Posts: 1,386
Thanks: 10
Thanked 40 Times in 34 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Tommyboy7777 View Post
Thats what i figured,guess i had to hear it from someone to make sure!!lol
Make sure you take a good look at the charging system and batteries, low voltage is most likely why the ficm power supply is failing.
Cranking voltage should be 10.8 or higher during the engine cranking, good strong batteries are in the high 11 volt range and alternator if OEM should be in the 13 volt range while running but will drop to high 12 volt range once everything is charged up.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:35 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors